Closed Bug 1508041 Opened 4 years ago Closed 4 years ago

[WAYLAND] User agent shows X11

Categories

(Core :: Widget: Gtk, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox65 --- affected

People

(Reporter: coolx67, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:65.0) Gecko/65.0 Firefox/65.0

Steps to reproduce:

open firefox with wayland backend
go to menu> troubleshooting 




Actual results:

user agent shows X11 even gnome uses Wayland session and in firefox wayland backend is enabled


Expected results:

should have shown correct user agent information
Reproduced on Ubuntu 16.04 Wayland Weston (not sure what is the proper way to version it) on Firefox Nightly 65.0a1 20181120220133.
Blocks: wayland
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Gtk
Ever confirmed: true
Product: Firefox → Core
Maybe this is a feature, not a bug?

I am not convinced that it is a good idea to expose information such as the system's underlying windowing system because it is rather irrelevant. Also it would make the user less anonymous by providing more data for fingerprinting that can be used for tracking.

https://panopticlick.eff.org/
Yes, better to remove that completely but definitely not expose the backend specifically.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX

thinking it should be 'Wayland like X11' ;)

So why is the status WONTFIX? Isn't the solution then to just remove information about the windowing system from the User Agent?

Correct protocol is at about:config. IMHO the X11 string should be removed from UA string.

You need to log in before you can comment on or make changes to this bug.