Closed Bug 1508221 Opened Last year Closed Last year

Crash in _chkstk | CreateNotificationBlock

Categories

(Core :: Audio/Video, defect, critical)

Unspecified
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1427011

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-75878fcf-6cf2-40b0-8e21-97c2a0181119.
=============================================================

Top 7 frames of crashing thread:

0 mmdevapi.dll _chkstk 
1 mmdevapi.dll CreateNotificationBlock 
2 mmdevapi.dll ATL::CAtlArray<ATL::CComQIPtr<IMediaNotificationCallback, &_GUID const IID_IUnknown>, ATL::CComQIPtrElementTraits<IMediaNotificationCallback, &_GUID const IID_IUnknown> >::~CAtlArray<ATL::CComQIPtr<IMediaNotificationCallback, &_GUID const IID_IUnknown>, ATL::CComQIPtrElementTraits<IMediaNotificationCallback, &_GUID const IID_IUnknown> > 
3 ntdll.dll TppSimplepExecuteCallback 
4 ntdll.dll TppWaiterpDoTransitions 
5  @0x9012a 
6 ntdll.dll EtwTraceMessageVa 

=============================================================

This seem to be audio-related, maybe a driver bug? It's specific to Windows 7 apparently.
Moving to Core :: A/V based on comment #0 and googling for what mmdevapi is... hopefully people there can work out what's going on here.
Component: General → Audio/Video
Product: Firefox → Core
Paul, can you help me with this one, mmdevapi.dll and ntdll.dll are system libraries. Not sure what is going on here ...
Flags: needinfo?(padenot)
A variant on 1427011.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(padenot)
Resolution: --- → DUPLICATE
Duplicate of bug: 1427011
It might be worth moving the crash signature of this bug over to bug 1427011 to track it. One thing I hadn't noticed before is that most crashes have 0xffffffffffffffff as the crashing address and _chkstk() is a routine used to allocate large structures on the stack. So it might be an overflow of some sort.
You need to log in before you can comment on or make changes to this bug.