Closed Bug 1508361 Opened Last year Closed Last year

Changes to TabsToolbar element in userChrome.css not working anymore since 65.0a1

Categories

(Firefox :: Toolbars and Customization, defect)

Unspecified
All
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- affected

People

(Reporter: saturos.ice, Unassigned)

Details

Attachments

(1 file)

12.05 KB, application/x-zip-compressed
Details
Attached file userChrome.zip
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0; Waterfox) Gecko/20100101 Firefox/56.2.5

Steps to reproduce:

Windows 10 x64. Firefox/Nightly x64. I am sometimes using Firefox Nightly version still. Attached is my userChrome.css, which I use to make the ui look like it should, still. Comment lines may be removed without changing the described issue, also the import of a secondary css to change back the icon theme. I just kept them in for completeness.. Last week I got the update to 65.0a1 (got updates since then as well, however no more version or issue change so far), with new version welcome display and stuff. From Firefox native "customization" options I have: activated permanent title bar (as otherwise doubleclicking the tabbar will shrink the window or even drag it somewhere, instead of open a new tab - who needs drag-space?), activated permanent menu bar, activated permanent bookmarks toolbar, normal item density, bright theme. No ui customizing add-ons.


Actual results:

The tab-bar now is below menu bar and above nav-bar.


Expected results:

Bars in order - top-down: Title-, menu-,nav-,bookmarks-,tab-bar. The tab-bar used to show up >below< the bookmarks toolbar.
I managed to reproduce this issue on Windows 10, Ubuntu 16.04, Mac OS, on Nightly 65.0a1 (2018-11-23).
Status: UNCONFIRMED → NEW
Component: Untriaged → CSS Parsing and Computation
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Version: 65 Branch → Trunk
This is likely because the DOM structure in the browser window changed in bug 1356920, and your userChrome.css's selectors are no longer up-to-date.

Unfortunately, userChrome.css modifications are not a usecase that we support, so this is a WONTFIX. Users with userChrome.css files are ultimately on their own to develop and maintain them.

You might consider reaching out to communities of like-minded users who might have similar customization needs. I've heard good things about the FirefoxCSS subreddit at https://www.reddit.com/r/FirefoxCSS.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
Component: CSS Parsing and Computation → Theme
Product: Core → Firefox
Component: Theme → Toolbars and Customization
(In reply to saturos.ice from comment #0)
> Actual results:
> 
> The tab-bar now is below menu bar and above nav-bar.

Although I have some sample rules on userchrome.org, I am not looking ahead to Firefox 65 at this point. You should try the rules Aris maintains here:

https://github.com/Aris-t2/CustomCSSforFx

When you click into the classic folder, click userChrome.css, and use Find (Ctrl+f) for TABS BELOW, you can discover the list of style sheets containing rules for Firefox 65 and adopt the ones applicable to your Firefox.
You need to log in before you can comment on or make changes to this bug.