Closed Bug 1508375 Opened Last year Closed Last year

Add Instagram to tp6

Categories

(Testing :: Raptor, enhancement)

Version 3
enhancement
Not set

Tracking

(firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: davehunt, Assigned: Bebe)

References

Details

Attachments

(5 files)

This tracks adding Instagram to tp6. In the absence of a test account, let's just create our own, follow a few high profile accounts, and add record a pageset for playback.
Depends on: 1508392
Excited to see how Instagram will look in mitmproxy!

A few things to consider (IMO) regarding content that we actually bring into production:

- it would be great if at least one dev on the perf team could review any proposed content for new tp6 pages which require a login; just to ensure the content is sufficient (i.e. does the instagram acct need to follow a certain number of instagram accounts, have a minimum number of postings, etc)?

- also for dev, is a hero element (or multiple) required, and if so where in the page?

- should we be following real-life instagram accounts or should we be creating a suite of test accounts that follow one another?

- also, what personal info should be used for the account holder's name, email, etc. (what if a phone number is required?)

- more generally is the content 'appropriate' / safe

Just want to be extra sure new content meets the needs of dev, and to try to avoid having to correct any recordings already in production etc. Thanks!
Created bug to upload the recording Bug 1510608
Depends on: 1510608
Ran your latest update (thanks :bebe) and this is what Instagram looks like via the mitmproxy playback in Raptor. Note: It looks the same on google Chrome.
Attachment #9028680 - Flags: feedback?(fstrugariu)
Attachment #9028680 - Flags: feedback?(dave.hunt)
(In reply to Florin Strugariu [:Bebe] from comment #6)

> https://treeherder.mozilla.org/#/jobs?repo=try&revision=c687c5e03bdc2316f86ed9f2a7573e57be0b22d0

Try run looks good; I added some more jobs (raptor-tp6-7 on google chromium on windows).
As I noted in the phabricator review - I'm fine with landing this now as long as you're happy with the content (comment 7) and the rest of the try runs are green (comment 8).
Comment on attachment 9028680 [details]
Screenshot_2018-11-29 Instagram.png

There appears to be a lot of missing image content. Is this expected?
Attachment #9028680 - Flags: feedback?(dave.hunt)
When I tried the first recording that :Bebe made, the photos were displayed. Then with the latest one the image is gone - I'm wondering if that 'turn on notifications' popup is the cause?
Attached image insta.png
I ran the test locally after i deleted all the content from /mozilla-central/obj-x86_64-pc-linux-gnu/testing/raptor

this is what i got on my end. 

I will run the tests on other OS
:davehunt :rwood on what OS are you seeing missing images?
How do you take that screenshot?
Flags: needinfo?(rwood)
Flags: needinfo?(dave.hunt)
I haven't run the test, I just noticed the missing images in Rob's screenshot.
Flags: needinfo?(dave.hunt)
(In reply to Florin Strugariu [:Bebe] from comment #14)
> :davehunt :rwood on what OS are you seeing missing images?
> How do you take that screenshot?

OSX, after I did a new build. The image isn't there (took the screenshot via Firefox screenshot).
Flags: needinfo?(rwood)
Tested it with the latest build on Linux and works fine
I will search for a mac and try to build
Pulled latest inbound, blew away my obj.../, applied your raptor-tp6-7 instagram patch, and ran locally on my OSX - here's the screnshot taken during raptor mitmproxy playback - unfortunately the image still doesn't appear.
(In reply to Florin Strugariu [:Bebe] from comment #19)
> I ran the tests with the script implemented in Bug 1512615 
> 
> We got good results on all platforms
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=b2c35de603ddef96a8e65f0f5040b47bc6985647&selectedJob=2
> 16171312

Interesting, so in production it is working fine. When I run locally on OSX the instagram image never appears - no matter if I take a screenshot or not, the image never appears. Maybe it's a race condition happening locally, where the last event we are measuring is being received right before the image is being displayed or something. I'm fine with going ahead if it is working fine in production.
With the latest update, and latest Nightly, the Instagram image is now appearing for me also when run locally on OSX on both Firefox and Chrome. Nice!

I also see that an entry for the new tp6-7 has been added to the Raptor Wiki and the raw source from the playback is in the perf-automation github repo. This is ready to land. I'll land it on your behalf :bebe via lando.
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c358cdc9533
Add Instagram to tp6 r=rwood,davehunt rwood
https://hg.mozilla.org/mozilla-central/rev/3c358cdc9533
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Attachment #9028680 - Flags: feedback?(fstrugariu)
You need to log in before you can comment on or make changes to this bug.