[Wayland]Text cursor leaves remnants when moved

RESOLVED FIXED in Firefox 68

Status

()

defect
P3
normal
RESOLVED FIXED
7 months ago
2 months ago

People

(Reporter: jcdawes92, Assigned: stransky)

Tracking

(Blocks 2 bugs)

65 Branch
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Type into a text box, such as the one to log a bug here, then press the left cursor key a few times.  


Actual results:

This will leave a trail of vertical remnants of the text cursor as it moves.  Only seems to happen on left moves, not right


Expected results:

No remnants should be left behind
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Reporter

Updated

7 months ago
Blocks: wayland
Priority: -- → P3
Component: Widget: Cocoa → Widget: Gtk
Assignee

Comment 1

3 months ago

I do see that too but only on 4K display. I can't reproduce on lower resolutions. I suspect it's a bug in mutter/gnome, there's nothing Firefox can fix here.

Assignee

Comment 2

3 months ago

This can be also caused by gfx card/driver, can you attach content of about:support page?

Flags: needinfo?(jcdawes92)
Reporter

Comment 3

3 months ago
Posted file about:support
Flags: needinfo?(jcdawes92)
Reporter

Comment 4

3 months ago

Hi Martin,
I don't get this effect in anything else on Wayland, for example gedit which uses the same cursor.
Also I don't get the problem if I start Firefox on Xwayland, so it seems pretty specific.

Assignee

Comment 5

3 months ago

(In reply to jcdawes92 from comment #4)

Hi Martin,
I don't get this effect in anything else on Wayland, for example gedit which
uses the same cursor.
Also I don't get the problem if I start Firefox on Xwayland, so it seems
pretty specific.

Yes, I can confirm that.

Assignee

Updated

3 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 6

3 months ago

Can you please try to enable webrender/GL backend? Set layers.acceleration.force-enabled to true at about:config. Thanks.

Flags: needinfo?(jcdawes92)
Assignee

Comment 7

3 months ago

Also do you use screen scaling/ HiDPI displays? I can reproduce only when I have 200% screen scale set.

Assignee

Comment 8

3 months ago

I think I have a patch for it.

Flags: needinfo?(jcdawes92)
Assignee

Comment 9

3 months ago

We have rendering artifacts when sceen scale is set and damage size/position is odd number.
It's caused by round error so update the size/position accordingly.

Reporter

Comment 10

3 months ago

Hi Martin,
yes, I am using a HIDPI display with 200% scaling.
Turning on webrender/GL backend makes a small difference. There are fewer remnants and they clean themselves up after a few seconds or when something else is updated.
For example, while entering this text, if I hold down left-arrow I get loads of remnants for a few seconds, then it suddenly clears up.

Assignee

Updated

2 months ago
Keywords: checkin-needed
Assignee

Comment 11

2 months ago

(In reply to jcdawes92 from comment #10)

Hi Martin,
yes, I am using a HIDPI display with 200% scaling.
Turning on webrender/GL backend makes a small difference. There are fewer
remnants and they clean themselves up after a few seconds or when something
else is updated.
For example, while entering this text, if I hold down left-arrow I get
loads of remnants for a few seconds, then it suddenly clears up.

The webrender/GL artifacts may be a different bug. This should be fixed in the SW rendered with this patch at least.

Assignee

Updated

2 months ago
Blocks: 1543600

Comment 12

2 months ago

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/38b3fac27d90
Fix round error when damage rect size/position is odd number and scale factor is used, r=lsalzman

Keywords: checkin-needed

Comment 13

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → stransky
You need to log in before you can comment on or make changes to this bug.