Enable producing full frame animated images by default

RESOLVED FIXED in Firefox 65

Status

()

P3
normal
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: aosmond, Assigned: aosmond)

Tracking

(Blocks: 1 bug)

Trunk
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 months ago
I was going to land this as part of recycling, but let's just get it now on its own. It will be good to have a nightly produced with just this setting.
(Assignee)

Comment 2

4 months ago
Also, fix a minor bug where when we discard an animated image that is a
full frame animated image, we need to reset
AnimationState::mCompositedFrameInvalid to false, just like we do for
animated images blended by FrameAnimator. This is because it is used as
part of our state checking in FrameAnimator::GetCompositedFrame before
we are willing to yield frame data.
(Assignee)

Comment 4

4 months ago
Apparently it is also hard if you somehow lost most of the patch in the push...for real this time:

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=919d7a8006a516c8f9549bb6278a76641bf71170
(Assignee)

Updated

4 months ago
Assignee: nobody → aosmond
Status: NEW → ASSIGNED

Comment 5

4 months ago
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c7a3fc19c85
Enable animated images producing full frames by default. r=tnikkel
(Assignee)

Updated

4 months ago
Keywords: dev-doc-needed
(Assignee)

Updated

4 months ago
Keywords: dev-doc-needed
(Assignee)

Comment 6

4 months ago
https://hg.mozilla.org/mozilla-central/rev/3c7a3fc19c85ebca0be908143148c388f9d36f04
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1447351
Depends on: 1509408
(Assignee)

Updated

4 months ago
Depends on: 1510601
status-firefox65: affected → fixed
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.