Switch Android builds to clang 7 again

RESOLVED FIXED in Firefox 65

Status

defect
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

6 months ago
Bug 1492663 upgraded those builds to clang 7, and bug 1503330 brought them back to clang 6 because of speedometer regressions.

Bisecting llvm trunk between clang 6 and 7 identified the regression as caused by https://github.com/llvm-mirror/llvm/commit/031332e78887f4658e2d7a2f7541827c2ca9baf5 . I filed this as https://bugs.llvm.org/show_bug.cgi?id=39717 but it's entirely possible it won't be changed.

However, we can disable the outliner manually on clang 7, allowing to upgrade again.

No amount of squinting makes me see an actual regression on arm, only aarch64, so we'll upgrade both.
Assignee

Comment 1

6 months ago
It's enabled by default as of clang 7 with -Oz on aarch64 (that is,
afaict, the only platform where it's enabled), and regresses our
performance on speedometer.
Assignee

Comment 2

6 months ago
Bug 1492663 upgraded those builds to clang 7, and bug 1503330 brought
them back to clang 6 because of speedometer regressions.

With the previous change, the regression doesn't happen any more,
allowing to upgrade again.

Depends on D12394

Comment 3

6 months ago
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/6f3303d415f7
Disable the machine outliner on Android. r=dmajor
https://hg.mozilla.org/integration/autoland/rev/8540104bb0bd
Switch Android builds to clang 7 again. r=dmajor

Comment 4

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6f3303d415f7
https://hg.mozilla.org/mozilla-central/rev/8540104bb0bd
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
See Also: → 1520149
You need to log in before you can comment on or make changes to this bug.