Closed Bug 1508622 Opened 1 year ago Closed 1 year ago

Crash in webrtc::videocapturemodule::DeviceInfoLinux::HandleEvents

Categories

(Core :: WebRTC: Audio/Video, defect, P2, critical)

Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Usul, Assigned: dminor)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-03b04d6c-15fc-43cc-8580-ad05f0181120.
=============================================================

Top 8 frames of crashing thread:

0 libxul.so webrtc::videocapturemodule::DeviceInfoLinux::HandleEvents media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc:75
1 NimbusSans-Bold.otf NimbusSans-Bold.otf@0x5e5f 
2 libxul.so rtc::PlatformThread::Run media/webrtc/trunk/webrtc/rtc_base/platform_thread.cc:343
3 memfd:pulseaudio (deleted) memfd:pulseaudio @0xfb1f167 
4 libpthread-2.28.so libpthread-2.28.so@0x1c367 
5 libxul.so rtc::PlatformThread::StartThread media/webrtc/trunk/webrtc/rtc_base/platform_thread.cc:220
6 libpthread-2.28.so libpthread-2.28.so@0x858d 
7 libc-2.28.so libc-2.28.so@0xfd592 

=============================================================

I was listening and validating Common Voice samples.
This first appeared in the 20181119100448 build.
Blocks: 1376873
Keywords: regression
Hi Ludovic, can you provide steps to reproduce? What site were you on when you were the browser crashed? Did the crashes you reported in Bug 1508947 and Bug 1508614 also occur while listening to common voice samples? A crash in DeviceInfoLinux implies that you were trying to share your camera on a WebRTC call. Can you confirm that is the case? Thanks!
Flags: needinfo?(ludovic)
(In reply to Dan Minor [:dminor] from comment #3)
> Hi Ludovic, can you provide steps to reproduce? What site were you on when
> you were the browser crashed? Did the crashes you reported in Bug 1508947

So I had done some voice "work". But that crash happened when I went to coinbase.com and they asked if I could verify myself. This triggers the process of the camera being up so I can take a picture of my ID and they can then analyze it.

STR:
 log on coinbase.com
 start your account verification an inlinepopup shows up asking for video. Say yes in FF -> crash.
Flags: needinfo?(ludovic)
(In reply to Ludovic Hirlimann [:Usul] from comment #4)
> (In reply to Dan Minor [:dminor] from comment #3)
> > Hi Ludovic, can you provide steps to reproduce? What site were you on when
> > you were the browser crashed? Did the crashes you reported in Bug 1508947
> 
> So I had done some voice "work". But that crash happened when I went to
> coinbase.com and they asked if I could verify myself. This triggers the
> process of the camera being up so I can take a picture of my ID and they can
> then analyze it.
> 
> STR:
>  log on coinbase.com
>  start your account verification an inlinepopup shows up asking for video.
> Say yes in FF -> crash.

Thanks! Is sharing your camera working fine on sites like: http://mozilla.github.io/webrtc-landing/gum_test.html or https://appear.in/dminor?
(In reply to Dan Minor [:dminor] from comment #5)

> Thanks! Is sharing your camera working fine on sites like:
> http://mozilla.github.io/webrtc-landing/gum_test.html or
> https://appear.in/dminor?

yes !
Rank: 15
Component: WebRTC → WebRTC: Audio/Video
Priority: -- → P2
Assignee: nobody → dminor
Duplicate of this bug: 1508614
Duplicate of this bug: 1508947
I created a coinbase account and was not able to reproduce the crash when verifying my id, but that isn't really surprising, based on how messed up the call stack is, I would guess this is timing dependent.

The inotify code was written for Firefox as far as I can tell and so has not changed in the update. The rest of the file has had some code style fixes applied to it but appears the same. There have been changes to PlatformThread with the update, I'll look there next.
if you let me know what you want I can try to do what's needed if I can still repro, haven't tried in 3 days.
(In reply to Ludovic Hirlimann [:Usul] from comment #10)
> if you let me know what you want I can try to do what's needed if I can
> still repro, haven't tried in 3 days.

Thanks you. It would be great if you could see if it still repros with current Nightly. If it does still repro, do you mind trying the build from this try job: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d727029ebdfc2acb1f73b71d32277fa0269e37bf. It changes the code to run on the newer PlatformThread interface. I wouldn't expect it to make a difference, but it seems like an obvious first thing to try.
I didn't carsh with latest build.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.