[remote-dbg-next] about:devtools-toolbox header is unreadable in dark theme

VERIFIED FIXED in Firefox 65

Status

P1
normal
VERIFIED FIXED
3 months ago
19 days ago

People

(Reporter: jdescottes, Assigned: ogasidlo)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 65

Firefox Tracking Flags

(firefox65 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 months ago
Created attachment 9026382 [details]
image.png

STRs:
- open DevTools, go to settings and enable dark theme
- open about:debugging
- inspect any tab

The header text is black on dark gray and therefore unreadable.
(Reporter)

Updated

3 months ago
Blocks: 1494541
No longer blocks: 1462208
Priority: -- → P2
(Assignee)

Updated

3 months ago
Assignee: nobody → ogasidlo
Status: NEW → ASSIGNED
Priority: P2 → P1
(Assignee)

Comment 1

3 months ago
Created attachment 9027532 [details]
Bug 1508651. Added header font color for dark theme. r=jdescottes

Comment 2

3 months ago
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3bc46ad43fde
Added header font color for dark theme. r=jdescottes,ladybenko

Comment 3

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3bc46ad43fde
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+

Hello,

I tried to reproduce this on the Fx Nightly 66.0a1 BuildID: 20181120220133 and I can't reproduce this issue. Can you please help shed some light on this issue? Can you still reproduce this issue? If so maybe there are more steps or some prerequisites?

Thank you.

Flags: needinfo?(jdescottes)
(Reporter)

Comment 5

24 days ago
  • open devtools
  • go to devtools settings
  • select dark theme
  • go to about:debugging in any tab
  • select Tabs category on the left
  • click on any Debug button
  • this should open a tab starting with "about:devtools-toolbox"
  • check the header's text color is readable
Flags: needinfo?(jdescottes)

Hello,

Thank you very much for the additional steps.

I was able to reproduce this issue using Fx 65.0a1, build ID: 20181120220133, on Windows 10 x64, macOS X 10.13 and Ubuntu 18.04 LTS.

I can confirm this issue is fixed, I verified using Fx 65.0 RC-build2, build ID: 20190124174741, on Windows 10 x64, macOS X 10.13 and Ubuntu 18.04 LTS.

Status: RESOLVED → VERIFIED
status-firefox65: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.