Closed Bug 1508695 Opened 2 years ago Closed 1 year ago

Incorrect or missing tracking flags on search results in REST API

Categories

(bugzilla.mozilla.org :: API, defect, P1)

Production
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: dylan, Assigned: dylan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
Details | Review
Attached file GitHub Pull Request (obsolete) —
:glob mentioned a user was seeing strange results when searching for multiple bugs.

The behavior is wrong or missing tracking flags. Yet if you search for a single bug, the tracking flags are correct. This lead me to believe it's a bug in Bugzilla->active_custom_fields and that appears to be the case.
Summary: Incorrect or missing track flags on search results → Incorrect or missing tracking flags on search results in REST API
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
That was quick. Thanks!

When do you think this be deployed?
The deployment bug is filed, and we're hoping today
This has to be backed out due to memory usage problems
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I've noticed the problem with fields which are not tracking flags too. The 'flags' field for example. cf_backlog too, but I guess this one is the same as tracking flags?
(In reply to Marco Castelluccio [:marco] from comment #5)
> I've noticed the problem with fields which are not tracking flags too. The
> 'flags' field for example. cf_backlog too, but I guess this one is the same
> as tracking flags?

yes, cf_backlog is implemented as a tracking flag.

Was anything changed recently with the non-search case too?
I was downloading bugs using a list of IDs, and it was working nicely.
Recently instead, the tracking/status/etc. flags are sometimes missing.

Flags: needinfo?(dylan)
Component: Search → API
See Also: → 1528994
Status: REOPENED → ASSIGNED
Flags: needinfo?(dylan)
Priority: -- → P1
Duplicate of this bug: 1528994
Attached file GitHub Pull Request
Attachment #9026429 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.