Show a notification icon after automatically dismissing permission prompts

RESOLVED FIXED in Firefox 67

Status

()

defect
P1
normal
RESOLVED FIXED
6 months ago
5 days ago

People

(Reporter: gerhard.grossmann, Assigned: johannh)

Tracking

(Blocks 2 bugs)

63 Branch
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed, firefox68 fixed)

Details

Attachments

(3 attachments)

Reporter

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

Most of the time web notifications are annoying and intrusive – even more this message pane popping up to ask for permission. It can only be closed if I make a decision right now. Therefore I search for a way to block notifications by default – but still get informed that a website offers it.

I tried checking the checkbox in the permission options to block new requests for showing notifications.


Actual results:

With this setting checked I no longer get informed that a website offers notifications at all. But sometimes these notifications are very practical, e.g. on Skype, so I’d like to have a choice.


Expected results:

Although I don’t want to be asked for permissions when the website is loaded I want the possibility to decide that later. So I need to be informed about this option, e.g. with an icon in the url bar (like it’s done when content blocking is active or the website offers an RSS feed).

There’s a setting permissions.default.desktop-notification, but it seems to hide the informing icon when the value is not 0. I didn’t find a documentation and don’t know what it’s doing.

Updated

6 months ago
Blocks: 1259207
Component: Untriaged → Notifications and Alerts
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
I personally wanted it to work this way when we did our permission prompt redesign but UX was concerned we'd end up showing a bunch of icons with a strikethrough.
Component: Notifications and Alerts → Site Identity and Permission Panels
Product: Toolkit → Firefox
Reporter

Comment 2

6 months ago
I can understand this argument, MattN. Personally I don’t think it’s that probable to get a bunch of icons because therefore a site has to request a lot of permissions. And that would reveal something about the website, too, so maybe it’s good to know for the user.

Alternative design idea:
At the moment there’s a grey dot on the [i] icon in the url bar when a site has permissions granted by default – in the attached screenshot because I decided in my settings that duckduckgo.com is allowed to save cookies permanently. This dot could have another colour (or/and form like × for accessibility) once at least one permission would have been requested but was blocked by default; compare with the orange dot over the download icon when a file transfer was interrupted.
Assignee

Updated

3 months ago
Blocks: 1375683
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Hey, Can I work on this issue?

Assignee

Comment 4

2 months ago

Hi Monika, this issue is a little too complicated and needs a bit too much UX consideration to be a good mentored bug. Thanks!

Assignee

Updated

2 months ago
Priority: P3 → P2
Assignee

Updated

2 months ago
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P2 → P1
Assignee

Updated

2 months ago
Summary: Option to block web notifications by default with icon showing → Show a notification icon after automatically dismissing permission prompts
Assignee

Comment 5

2 months ago

This adds support for a "post-prompt" that appears dismissed (only the icon showing) when
the browser decides to automatically deny a permission request from a site (either based on
internal heuristics or because the user prefers not to receive permission prompts).

In order to move quickly and not overload the patch I have only implemented the post-prompting
for desktop-notification so far, however, implementing it for other permissions should be
a trivial follow-up.

Assignee

Comment 6

2 months ago

This permission checking should be handled by PermissionUI.jsm, to be able to apply custom heuristics
for denying the permission and also to be able to "post-prompt" after denying automatically.

Comment 10

2 months ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b73c90f76abd
Show a notification icon after automatically dismissing permission prompts. r=MattN
https://hg.mozilla.org/integration/autoland/rev/01fb911f1f2d
Don't prematurely check for permissions in pushManager.subscribe() permission requests. r=lina

Comment 11

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee

Updated

a month ago
Blocks: 1544424
Assignee

Comment 12

29 days ago

Comment on attachment 9054509 [details]
Bug 1508961 - Show a notification icon after automatically dismissing permission prompts. r=MattN

Beta/Release Uplift Approval Request

  • User impact if declined: Needed for bug 1536454
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is preffed-off by default, has extensive tests and has baked for a long time on Nightly.
  • String changes made/needed: None
Attachment #9054509 - Flags: approval-mozilla-beta?
Assignee

Updated

29 days ago
Attachment #9054510 - Flags: approval-mozilla-beta?

Comment on attachment 9054509 [details]
Bug 1508961 - Show a notification icon after automatically dismissing permission prompts. r=MattN

Preffed off and spent 3 weeks on nightly before the uplift, approved for 67 beta 14, thanks.

Attachment #9054509 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9054510 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.