Closed Bug 15090 Opened 20 years ago Closed 14 years ago

Make expat an XPCOM component that exposes SAX interfaces

Categories

(Core :: XML, enhancement, P3)

All
Windows NT
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 315826
Future

People

(Reporter: nisheeth_mozilla, Assigned: nisheeth_mozilla)

References

Details

(Keywords: helpwanted)

Attachments

(2 files)

Status: NEW → ASSIGNED
Target Milestone: M14
Accepting bug and setting milestone to M14...

Ccing brad who's making this happen.  Go, Brad!
Adding vidur to the cc list.
Whiteboard: HELP WANTED
Bulk moving all M14 non-beta stopper bugs to M17...
Keywords: helpwanted
Whiteboard: HELP WANTED
This would simplify implementation of XML-RPC greatly. Adding our keyword, so we
don't miss a thing. Adding myself on the CC list.
Keywords: zopestudio
Moving bugs out by one milestone...
Target Milestone: M17 → M18
Marking this M20...
Target Milestone: M18 → M20
*** Bug 35234 has been marked as a duplicate of this bug. ***
*** Bug 35234 has been marked as a duplicate of this bug. ***
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Target Milestone: M20 → Future
For the XML-RPC client component I had to write my own XML Parser in Javascript
because of this, and the Jabber.org team will have to do the same for their
component.

This is unnessecary, redundant work with Expat part of Mozilla, but as it isn't
exposed as a scriptable XPCOM component. We _could_ write a XPCOM scriptable SAX
compliant XML parser in Javascript, as we then would "only" have two XML parsers
in Mozilla, in stead of a whole host, but this still seems to me to be overkill
and a waste of our time.
I've attached a .tar.gz of the start of a SIMPLE sax parser in javascript, it
needs quite a bit of work, but 80% of the most popular use of it is done.

The intention is that this will develop into an XPCOM component that can be
shared minimally between XML-RPC and Jabber, and possibly anything else that
needs to parse chunks of XML or have raw access to the parser and not a DOM.

Also, the correct evolution would be to replace this with an expat-based
component, whenever someone arrives w/ the time and talent to do so :)
Great! I'll try and integrate it into XML-RPC as a test this week.
QA Contact: chrisd → petersen
QA Contact: petersen → rakeshmishra
I may have gotten some work done on this:

  http://eXPatCOM.mozdev.org

without having known about this bug.
QA Contact: rakeshmishra → ashishbhatt
Severity: normal → enhancement
Summary: FEATURE: Make expat an XPCOM component that exposes SAX interfaces → Make expat an XPCOM component that exposes SAX interfaces
I'm going to mark this duplicate of bug 315826, since that's where the implementation that's now in the trunk happened.

*** This bug has been marked as a duplicate of 315826 ***
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.