Closed Bug 1509057 Opened Last year Closed Last year

Disable support for grouping separators in <input type=number> user input

Categories

(Core :: Layout: Form Controls, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

Details

(Whiteboard: [webcompat])

Attachments

(1 file)

In bug 974175 we changed the default behavior for serializing of <input type=number>'s value to stop outputting grouping separators in the serialized string. Given bugs like bug 1026994 and the fact that Chrome doesn't currently support grouping separators, I think it would be better to disable our support for grouping separators in user input too. At some point in the future when we have time to revisit this issue and consider it properly we can decide whether/how we can turn this on by default again.
Duplicate of this bug: 1350240
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/27fe8b1767f2
Disable <input type=number> support for grouping separators in user input. r=mats
Duplicate of this bug: 1026994
https://hg.mozilla.org/mozilla-central/rev/27fe8b1767f2
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Whiteboard: [webcompat]
You need to log in before you can comment on or make changes to this bug.