Closed Bug 1509147 Opened 2 years ago Closed 2 years ago

Rename payer and paymentMethod on nsIPaymentDetails to payerErrors and paymentMethodErrors respectively

Categories

(Core :: DOM: Web Payments, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: MattN, Assigned: dpino)

References

()

Details

(Whiteboard: [webpayments-reserve])

Attachments

(1 file, 4 obsolete files)

It's non-obvious that `nsIPaymentDetails.payer` or `nsIPaymentDetails.paymentMethod` actually contain errors, not information about the payer or paymentMethod. I had a hard time figuring out if these errors were passed to the front-end because of this. These should be renamed to add an "Errors" suffix to match `shippingAddressErrors`.

Front-end code and tests should be updated to reflect this.

Diego, would you prefer contributing to C++ or JS? This may be a good bug for you. Feel free to join #payments on irc.mozilla.org
Flags: needinfo?(dpino)
I have no preference. I like the idea of working on C++ code too, despite it has been a long time since I coded in C++. Possibly I can take simple C++ bugs like this one for a start.
Flags: needinfo?(dpino)
Attachment #9026932 - Flags: review?(MattN+bmo)
Assignee: nobody → dpino
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 9026932 [details] [diff] [review]
Bug-1509147-Rename-payer-and-paymentMethod-on-nsIPay.patch

Review of attachment 9026932 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great! I'll request DOM peer review now too. Thanks
Attachment #9026932 - Flags: review?(amarchesini)
Attachment #9026932 - Flags: review?(MattN+bmo)
Attachment #9026932 - Flags: review+
Make sure to run `./mach test dom/payments` too.
Update patch (`dom/payments/test/test_basiccarderrors.html` failed).
Attachment #9026932 - Attachment is obsolete: true
Attachment #9026932 - Flags: review?(amarchesini)
Attachment #9027018 - Attachment is obsolete: true
Attachment #9027020 - Flags: review?(amarchesini)
Updated patch (`dom/payments/test/test_payerDetails.html` failed).
Attachment #9027020 - Attachment is obsolete: true
Attachment #9027020 - Flags: review?(amarchesini)
Attachment #9027105 - Flags: review?(amarchesini)
Fixed failing test `test_retryPayment.html`.
Attachment #9027105 - Attachment is obsolete: true
Attachment #9027105 - Flags: review?(amarchesini)
Attachment #9027480 - Flags: review?(amarchesini)
After this many back and forth patch updates, I think the patch is ready for review now (no tests failing).
Attachment #9027480 - Flags: review?(amarchesini) → review+
Keywords: checkin-needed
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e9a02a8a62e5
Rename payer and paymentMethod on nsIPaymentDetails to payerErrors and paymentMethodErrors respectively r=baku
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e9a02a8a62e5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.