Perma test_input_event.html | uncaught exception - ReferenceError when Gecko 65 merges to Beta on 2018-12-03

VERIFIED FIXED in Firefox 65

Status

()

defect
P2
normal
VERIFIED FIXED
8 months ago
8 months ago

People

(Reporter: CosminS, Assigned: masayuki)

Tracking

unspecified
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65+ verified)

Details

Attachments

(2 attachments)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&revision=c4902419549a843d9dba6fa9b8dbfdc6563266f9&searchStr=e10s%2Cmochitest&selectedJob=213392430

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=213405092&repo=try&lineNumber=4811

This looks to be a regression from Bug 1504911. Masayuki, could you please take a look? 

18:41:56     INFO - TEST-PASS | dom/html/test/forms/test_input_event.html | input event shouldn't be dispatched if click event is cancelled 
18:41:56     INFO - Not taking screenshot here: see the one that was previously logged
18:41:56     INFO - TEST-UNEXPECTED-FAIL | dom/html/test/forms/test_input_event.html | uncaught exception - ReferenceError: event is not defined at checkIfInputIsEvent@http://mochi.test:8888/tests/dom/html/test/forms/test_input_event.html:60:5
18:41:56     INFO - @http://mochi.test:8888/tests/dom/html/test/forms/test_input_event.html:90:7
18:41:56     INFO - testUserInput2@http://mochi.test:8888/tests/dom/html/test/forms/test_input_event.html:204:9
18:41:56     INFO - 
18:41:56     INFO -     simpletestOnerror@SimpleTest/SimpleTest.js:1644:13
18:41:56     INFO -     testUserInput2@dom/html/test/forms/test_input_event.html:204:9
18:41:56     INFO - GECKO(4640) | JavaScript error: http://mochi.test:8888/tests/dom/html/test/forms/test_input_event.html, line 60: ReferenceError: event is not defined
18:41:56     INFO - TEST-PASS | dom/html/test/forms/test_input_event.html | input event should have been dispatched 
18:41:56     INFO - TEST-PASS | dom/html/test/forms/test_input_event.html | input event should not have been dispatched 
18:41:56     INFO - TEST-PASS | dom/html/test/forms/test_input_event.html | input event shouldn't be dispatched if click event is cancelled 
18:41:56     INFO - TEST-PASS | dom/html/test/forms/test_input_event.html | undefined assertion name 
18:41:56     INFO - TEST-PASS | dom/html/test/forms/test_input_event.html | input event shouldn't be dispatched on range input element for key changes that don't change its value 
18:41:56     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(masayuki)
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
This is an idiot mistake.  It refers window.event accidentally and it's still
disabled on Beta and Release channel.  Therefore, we should make it refer
aEvent instead.

On the other hand, it might be better to make our lint check whether test
refers window.event directly or not because it may check odd result
accidentally.
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/1df9d08586c5
Make test_input_event.html refer aEvent in checkIfInputIsEvent() rather than window.event r=smaug
https://hg.mozilla.org/mozilla-central/rev/1df9d08586c5
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Reopening because test_input_number_mouse_events.html still needs to be fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/8c72e35255c5
Make test_input_number_mouse_events.html refer evt in checkInputEvent() rather than window.event r=smaug
https://hg.mozilla.org/mozilla-central/rev/8c72e35255c5
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.