Closed Bug 1509527 Opened 3 years ago Closed 2 years ago

Update the values supported by our 'inputmode' implementation

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla75
Webcompat Priority P3
Tracking Status
firefox75 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

Details

(Keywords: dev-doc-complete, parity-chrome)

Attachments

(2 files)

The specification for 'inputmode' has changed a fair bit. The capitalization values have been spun out into a separate 'autocapitalize' attribute - bug 1425291 - and new values have been added.

Chrome shipped their implementation earlier this year. We should update and ship our implementation so that users on Android are less likely to be irritated by having the wrong keyboard come up.
I don't intend to investigate contenteditable support right now. That's still covered by bug 1424284.
Summary: Update our 'inputmode' implementation → Update the values supported by our 'inputmode' implementation

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:jwatt, could you have a look please?

Flags: needinfo?(jwatt)
Webcompat Priority: --- → ?

Is there any reason we shouldn't land this?

Flags: needinfo?(jwatt)

(oops)

Flags: needinfo?(jwatt)

I guess this one just got lost in whatever else I was doing at the time.

I've pushed to Try to see if we can land this now:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=70f25a23a533b4d529693dcc790487efd8158572

Seems like a few oranges related to inputs worth investigating.

Webcompat Priority: ? → P3

It would be nice to have support for inputmode=numeric when Fenix ships.

(In reply to Mike Taylor [:miketaylr] from comment #7)

Seems like a few oranges related to inputs worth investigating.

I guess that this is a simple mistake of test. defaultValue is "", not "auto".

I am currently trying to update this patch.

Try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=cea821fa7dd996dbd10a08b8af105727a4f1c30d

I updated this patch in the hope that it will make it easier to get it landed. If some failures comes up in
the try push, I will try to resolve that.

I already fixed the issue with "defaultValue" in dom/html/test/forms/test_input_attributes_reflection.html

I also file an issue as bug 1618754 to support inputmode=none.

Attachment #9129558 - Attachment description: Bug 1509527 - Updated patch → Bug 1509527 - Update the values supported by our 'inputmode' implementation.
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d46a58d9b825
Update the values supported by our 'inputmode' implementation. r=m_kato
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Regressions: 1625843
Flags: needinfo?(jwatt)
You need to log in before you can comment on or make changes to this bug.