CSD (No title bar) in 63 rendering weird

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
5 months ago
a month ago

People

(Reporter: haaning.frederik, Unassigned)

Tracking

(Blocks 1 bug)

63 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

Installed fresh Manjaro. I get this issue on all my devices including my ubuntu GNOME workstation and manjaro KDE laptop.


Actual results:

See screenshots. Sometimes if I open a fresh browser window I need to interact with it before it messes up the drawing.


Expected results:

Drawn the decorative buttons inline with the tabs and not made extra space above while placing the buttons in the upper right corner without margins. (See screenshot 183738 for expected behaviour)
(Reporter)

Comment 1

5 months ago
(Reporter)

Comment 2

5 months ago
(Reporter)

Comment 3

5 months ago
Also tried disabling all addons using safe mode. Problem still persists. Tried different themes. The problem occurred in a later version, most likely 63 and was not present before ever since CSD was introduced to Linux.

Comment 4

5 months ago
Setting as Core: XUL. Please correct if this is not the right component. Thanks.
Component: Untriaged → XUL
Product: Firefox → Core

Updated

5 months ago
Component: XUL → General
Product: Core → Firefox
Blocks: gtktitlebar
Component: General → Widget: Gtk
Product: Firefox → Core

Can you please test latest nightly (from https://www.mozilla.org/en-US/firefox/channel/desktop/) if you see this issue? Thanks!

Flags: needinfo?(haaning.frederik)
(Reporter)

Comment 6

3 months ago

Hi Martin, thanks for paying attention to this bug.

I ran the requested Nightly build and it certainly seems to have done it. I'm even logged in using my addons and all :) When can I expect this patch in the production builds?

Thanks!
/Frederik.

Flags: needinfo?(haaning.frederik)

I think this was fixed by Bug 1356920 so it should come in Firefox 65.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
(Reporter)

Comment 8

3 months ago

So I got the 65 release running and the title bar got sort of better (the button margins are better but the title bar is taller). So not quite fixed in stable 65. Nightly still works. Could it be something else?

(Reporter)

Comment 9

3 months ago

What's interesting is I noticed that a double right-click in the padded area will result in it temporarily disappearing reverting to the intended state.

(Reporter)

Comment 10

3 months ago
Posted image ff65.png
(Reporter)

Comment 11

3 months ago
Posted image ff65_2.png
(Reporter)

Comment 12

3 months ago
Posted image ff65_3.png
(Reporter)

Comment 13

a month ago

Still a problem in 66. Beginning to think it has something to do with my specific firefox opensuse-kde?

(In reply to haaning.frederik from comment #13)

Still a problem in 66. Beginning to think it has something to do with my
specific firefox opensuse-kde?

Please file a new bug for it and stat what exactly is broken. Also please test latest nightly. KDE is not well supported as it uses solid-csd decorations.

You need to log in before you can comment on or make changes to this bug.