Learn More links in the preferences should be sentence case ("Learn more" instead of "Learn More")

VERIFIED FIXED in Firefox 65

Status

()

defect
P5
normal
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: mwalkington, Assigned: xiangh4, Mentored)

Tracking

({good-first-bug})

unspecified
Firefox 65
Points:
---

Firefox Tracking Flags

(firefox65 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

6 months ago
The 'Learn More' links under the Browsing and Network Settings sections of Preferences > General should be sentence case, not title case. Sentence case is the predominant pattern in prefs for links. 

Current: Learn More

Proposed: Learn more
Comment hidden (obsolete)
We don't need new IDs to change the case, updating the FTL messages just for en-US would be enough.
Assignee

Comment 4

6 months ago
Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd like to try to fix it.

Comment 5

6 months ago
(In reply to haotian xiang from comment #4)
> Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd
> like to try to fix it.

Hi! We normally assign people's first bugs when they put up a patch. I also notice you've asked this question in a few bugs - I'd recommend picking just 1 to start with. Thank you!
Assignee

Comment 6

6 months ago
(In reply to :Gijs (he/him) from comment #5)
> (In reply to haotian xiang from comment #4)
> > Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd
> > like to try to fix it.
> 
> Hi! We normally assign people's first bugs when they put up a patch. I also
> notice you've asked this question in a few bugs - I'd recommend picking just
> 1 to start with. Thank you!

Hahaha. Because I joined an open source course in my university. They told me that I need pick 3 bugs and fixing them. So I just asked this question under several bugs.
Assignee

Comment 7

6 months ago
(In reply to undefined from comment #undefined)
> 

I've created a patch for this bug but I'm a little bit confused how to submit it. Can you help me with it?
Assignee

Comment 8

6 months ago
(In reply to haotian xiang from comment #6)
> (In reply to :Gijs (he/him) from comment #5)
> > (In reply to haotian xiang from comment #4)
> > > Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd
> > > like to try to fix it.
> > 
> > Hi! We normally assign people's first bugs when they put up a patch. I also
> > notice you've asked this question in a few bugs - I'd recommend picking just
> > 1 to start with. Thank you!
> 
> Hahaha. Because I joined an open source course in my university. They told
> me that I need pick 3 bugs and fixing them. So I just asked this question
> under several bugs.

I found a link (https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide) let me try it :D
Assignee

Comment 9

6 months ago
(In reply to :Gijs (he/him) from comment #5)
> (In reply to haotian xiang from comment #4)
> > Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd
> > like to try to fix it.
> 
> Hi! We normally assign people's first bugs when they put up a patch. I also
> notice you've asked this question in a few bugs - I'd recommend picking just
> 1 to start with. Thank you!

firefox-dev@firefox-dev:~/mozilla-central$ hg log -p -r bbcdb93f82dd
changeset:   440682:bbcdb93f82dd
tag:         modifying learn more
tag:         qbase
tag:         qtip
tag:         tip
user:        haotian xiang <xiangh4@uni.coventry.ac.uk>
date:        Sat Dec 01 12:12:01 2018 +0100
summary:     [mq]: modifying learn more

diff --git a/browser/locales/en-US/browser/preferences/preferences.ftl b/browser/locales/en-US/browser/preferences/preferences.ftl
--- a/browser/locales/en-US/browser/preferences/preferences.ftl
+++ b/browser/locales/en-US/browser/preferences/preferences.ftl
@@ -418,7 +418,7 @@ network-settings-title = Network Setting
 
 network-proxy-connection-description = Configure how { -brand-short-name } connects to the internet.
 
-network-proxy-connection-learn-more = Learn More
+network-proxy-connection-learn-more = Learn more
 
 network-proxy-connection-settings =
     .label = Settings…
==================================================================

Hi, This is the patch for this bug~ Thanks~

Comment 10

6 months ago
(In reply to haotian xiang from comment #8)
> (In reply to haotian xiang from comment #6)
> > (In reply to :Gijs (he/him) from comment #5)
> > > (In reply to haotian xiang from comment #4)
> > > > Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd
> > > > like to try to fix it.
> > > 
> > > Hi! We normally assign people's first bugs when they put up a patch. I also
> > > notice you've asked this question in a few bugs - I'd recommend picking just
> > > 1 to start with. Thank you!
> > 
> > Hahaha. Because I joined an open source course in my university. They told
> > me that I need pick 3 bugs and fixing them. So I just asked this question
> > under several bugs.
> 
> I found a link
> (https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide) let me
> try it :D

Bit confused - this links to https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch which links to https://moz-conduit.readthedocs.io/en/latest/phabricator-user.html - did you try to use phabricator ?

(In reply to haotian xiang from comment #9)
> firefox-dev@firefox-dev:~/mozilla-central$ hg log -p -r bbcdb93f82dd
> changeset:   440682:bbcdb93f82dd
> tag:         modifying learn more
> tag:         qbase
> tag:         qtip

You'll want to use `hg qfinish` to finalize the patch before submitting it. To amend it later, you can use `hg amend`.

> diff --git a/browser/locales/en-US/browser/preferences/preferences.ftl
> -network-proxy-connection-learn-more = Learn More
> +network-proxy-connection-learn-more = Learn more

This is only one of the 2 strings that need changing.
Assignee

Comment 11

6 months ago
Posted image 31543748012_.pic.jpg
So, there is only one line of 'Learn More' that I can change
Assignee

Comment 12

6 months ago
(In reply to haotian xiang from comment #11)
> Created attachment 9029194 [details]
> 31543748012_.pic.jpg
> 
> So, there is only one line of 'Learn More' that I can change

(In reply to :Gijs (he/him) from comment #10)
> (In reply to haotian xiang from comment #8)
> > (In reply to haotian xiang from comment #6)
> > > (In reply to :Gijs (he/him) from comment #5)
> > > > (In reply to haotian xiang from comment #4)
> > > > > Hi,I'm a newbie for fixing firefox bug.Can you assigning this bug to me.I'd
> > > > > like to try to fix it.
> > > > 
> > > > Hi! We normally assign people's first bugs when they put up a patch. I also
> > > > notice you've asked this question in a few bugs - I'd recommend picking just
> > > > 1 to start with. Thank you!
> > > 
> > > Hahaha. Because I joined an open source course in my university. They told
> > > me that I need pick 3 bugs and fixing them. So I just asked this question
> > > under several bugs.
> > 
> > I found a link
> > (https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide) let me
> > try it :D
> 
> Bit confused - this links to
> https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/
> How_to_Submit_a_Patch which links to
> https://moz-conduit.readthedocs.io/en/latest/phabricator-user.html - did you
> try to use phabricator ?
> 
> (In reply to haotian xiang from comment #9)
> > firefox-dev@firefox-dev:~/mozilla-central$ hg log -p -r bbcdb93f82dd
> > changeset:   440682:bbcdb93f82dd
> > tag:         modifying learn more
> > tag:         qbase
> > tag:         qtip
> 
> You'll want to use `hg qfinish` to finalize the patch before submitting it.
> To amend it later, you can use `hg amend`.
> 
> > diff --git a/browser/locales/en-US/browser/preferences/preferences.ftl
> > -network-proxy-connection-learn-more = Learn More
> > +network-proxy-connection-learn-more = Learn more
> 
> This is only one of the 2 strings that need changing.

After pulled the newest source code from site. And I find the UI is little bit different with what you attached in previous comment.

Comment 13

6 months ago
There is also https://hg.mozilla.org/mozilla-central/file/tip/browser/locales/en-US/browser/preferences/preferences.ftl#l427 in the source code. That's still there in the latest version of mozilla-central, and I still see the checkbox in an up-to-date mac nightly. I don't know why you don't. Have you checked the DOM (use the regular developer tools to inspect the page) - is it maybe hidden for some reason?

Updated

6 months ago
Assignee: nobody → xiangh4
Status: NEW → ASSIGNED
I've approved the patch, but in Lando I get "Repository is not supported by Lando.", which leaves me quite puzzled. Any clue?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 16

6 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/65ee8bd1ce81
change 'Learn More' to 'Learn more' in preferences.ftl to be consistent, r=flod

Comment 17

6 months ago
(In reply to Francesco Lodolo [:flod] from comment #15)
> I've approved the patch, but in Lando I get "Repository is not supported by
> Lando.", which leaves me quite puzzled. Any clue?

People in #phabricator on IRC said that it was probably uploaded via the web interface rather than using moz-phab / phabsend.

haotian: thanks for the patch - in future please use https://github.com/mozilla-conduit/review/blob/master/README.md to submit it. Thank you!
Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Comment 18

6 months ago
(In reply to :Gijs (he/him) from comment #17)
> (In reply to Francesco Lodolo [:flod] from comment #15)
> > I've approved the patch, but in Lando I get "Repository is not supported by
> > Lando.", which leaves me quite puzzled. Any clue?
> 
> People in #phabricator on IRC said that it was probably uploaded via the web
> interface rather than using moz-phab / phabsend.
> 
> haotian: thanks for the patch - in future please use
> https://github.com/mozilla-conduit/review/blob/master/README.md to submit
> it. Thank you!

Got it.

Comment 19

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/65ee8bd1ce81
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65

Comment 20

5 months ago
I have reproduced this bug with Nightly 65.0a1 (2018-11-26) on Windows 10, 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20181220174318
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

[testday-20181221]

Comment 21

5 months ago
I have reproduced this bug with Nightly 65.0a1 (2018-11-08) on ManjaroLinux 18.0.1, 64 Bit!

This bug's fix is verified with the latest Beta!

Build ID   : 20181220174318
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
QA Whiteboard: [testday-20181221]

Updated

5 months ago
Status: RESOLVED → VERIFIED
Attachment #9029215 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.