Closed Bug 1510855 Opened 6 years ago Closed 6 years ago

Latest nightlies move Titlebar buttonbox into TabsToolbar hbox

Categories

(Firefox :: Theme, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: CaptaPraelium, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Nothing


Actual results:

Titlebar buttonbox hbox is now contained within the TabsToolbar hbox
Tabbar is for tabs, not titlebar buttons


Expected results:

Titlebar buttonbox should be external to Tabstoolsbar buttonbox as it was previously

Link to Reddit post containing screenshots outlining the layout issue: https://www.reddit.com/r/FirefoxCSS/comments/a1ae1u/titlebar_buttonbox_is_now_part_of_tabbar_wat_pls/
I wanted to test this issue but I do not have enough information. Could you please provide clear steps about how to reproduce this issue?
Flags: needinfo?(CaptaPraelium)
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ab00b6e99fd65b651381c235f1ae95ed746e57a&tochange=e354a018b703c453e8afcda1f44f1d51456536f5

This is an intentional change introduced for performance reasons by bug 1356920. The structure won't be reverted considering this and the fact that userChrome.css customizations are unsupported (see for instance bug 1505927). It also looks like the reporter found a workaround in the aforementioned Reddit thread.

(In reply to Daniel_A[:daschilean] from comment #1)
> I wanted to test this issue but I do not have enough information. Could you
> please provide clear steps about how to reproduce this issue?

1. Open the Browser Toolbox [1].
2. Click the Arrow icon on the left, then one of the caption buttons in the main window (minimize, maximize, close).
3. Note the structure of the toolbar items.

Actual results:
window#main-window > toolbox#navigator-toolbox > vbox#titlebar > toolbar#TabsToolbar.browser-toolbar.titlebar-color > hbox.titlebar-buttonbox-container.titlebar-item > hbox.titlebar-buttonbox.titlebar-color > toolbarbutton.titlebar-button.titlebar-min / …-max / …-close

Expected results:
window#main-window > vbox#titlebar > hbox#titlebar-content > hbox#titlebar-buttonbox-container > hbox#titlebar-buttonbox.titlebar-color > toolbarbutton#titlebar-min.titlebar-button / …-max / …-close


[1] https://developer.mozilla.org/docs/Tools/Browser_Toolbox
Blocks: 1356920
Status: UNCONFIRMED → RESOLVED
Has Regression Range: --- → yes
Closed: 6 years ago
Component: Untriaged → Theme
Flags: needinfo?(CaptaPraelium)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.