Ctrl+ left/right - bad skipping

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: janousek, Assigned: mjudge)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The default feel in MS Windows (and not only there) when the Ctrl key is pressed
and now press navigation key (bellow Insert, Home, PgUp/Down etc.) - the caret
(actual cursor position for writing/editing) may skip by word left/right.
Mozilla in forms (textarea and input box) skips by one char left/right...

Comment 1

16 years ago
Behaves mormally on my system...

Win2kPro, Moz1.1-Alpha

Comment 2

16 years ago
also seems to work fine on my system: 
  win2kpro, tested w/ moz1.0.0 AND moz1.1a

I attempted to recreate this bug by typing words with spaces in the Additional
Comments box on this page, then hold ctrl and press the left arrow a bunch of
times.  Cursor moves by words, as it should.  I tried both left arrows, gray and
keypad, as well as both right arrows.  I've never seen this bug on any previous
build.  
I suggest:
WORKSFORME

Comment 3

16 years ago
WFM 2002061108/trunk/W2K
Pavel, could you provide your build ID/Mozilla version?
(Reporter)

Comment 4

16 years ago
I try this BUG again and NOW in this form it works correctly...

May be this situation arrives with some modules crashs together - keyboard
binding manager(?)...

When I'm browsing somewhere and sometime I lost ALL keyboard bindings, which is
standard and are propagate through main popup menu system. This BUG I weren't
sent to now because I'm not able repeat this situation corectly for more times.
I must close all window, kill the 'quick startup assistant' and now run Mozilla
again. Im' using Mozilla Main too, so if this situation (describer in this
paragraph) arrives in one window, in this time is seen in all window (not only
in tab's in curent window) and in Mail window(s) too...

PS: My build is oficial M1.0 - si Build ID is 2002053012

Comment 5

16 years ago
 -> Mike Judge, who is working on better word break detection in bug 98546.
Assignee: aaronl → mjudge

Comment 6

16 years ago
Works fine here, too (2002070204 on Win2k).

Comment 7

16 years ago
WFM with 2002090704/trunk/win2k.

reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.1)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.

Comment 8

16 years ago
no response from reporter for >30 days, resolving WFM.

reporter - if you can reproduce this bug with a recent build of mozilla, please
reopen. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.