javascript close statements cause mozilla to exit instead of just the tab

VERIFIED DUPLICATE of bug 32571

Status

VERIFIED DUPLICATE of bug 32571
17 years ago
10 years ago

People

(Reporter: jhaar, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Check out this form:

<form><input type="button" name="Close" onclick="return self.close()"
value="Close"></form>

That is supposed to close the current window. However I'd suggest that if it's
run within a tab - it should close the tab instead of the entire browser?

I *LOVE* tabs. I only run one browser windows with multiple tabs. You can
imagine the shock I got when mozilla shut down on me :-)

Keep up the great work!

Jason

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 32571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Eh.. thats not a dup of 32571

_this_ bug is about tabbed browsing...

Your testcase works fine in newer builds (I have 2002060700)

Bug 103452 was fixed around 4. June 2002.. so try a newer build :)

*** This bug has been marked as a duplicate of 103452 ***

*** This bug has been marked as a duplicate of 103452 ***
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.