Open Bug 1511921 Opened Last year Updated Last year

Crash in mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread

Categories

(Core :: DOM: Workers, defect, P3, critical)

x86_64
macOS
defect

Tracking

()

REOPENED
Tracking Status
firefox65 --- affected
firefox66 --- affected
firefox67 --- affected

People

(Reporter: mb8672, Unassigned)

Details

Crash Data

This bug was filed from the Socorro interface and is
report bp-3461472d-d566-40a3-8c15-f33e10181204.
=============================================================

Top 10 frames of crashing thread:

0  @0x7fff71fd7e59 
1 XUL mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread xpcom/threads/Mutex.h:66
2 XUL mozilla::dom:: dom/workers/WorkerDebuggerManager.cpp:41
3 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1157
4 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:468
5 XUL mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:88
6 XUL nsBaseAppShell::Run ipc/chromium/src/base/message_loop.cc:314
7 XUL nsAppShell::Run widget/cocoa/nsAppShell.mm:745
8 XUL XRE_RunAppShell toolkit/xre/nsEmbedFunctions.cpp:915
9 XUL XRE_InitChildProcess ipc/chromium/src/base/message_loop.cc:314

=============================================================
Status: UNCONFIRMED → NEW
Ever confirmed: true
19 crashes in the last 2 days, crashes started using 20181204215402. Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=01d0813d8203d78613fc33a3e8e32627c1300b50&tochange=0a65dda20ade2c24bf42fb22bfd7169b320b732e
Crash Signature: [@ mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] → [@ mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] [@ mozilla::detail::MutexImpl::lock | mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread]
Priority: -- → P3
Crashes are happening more frequently (4-5 times a day) since reporting with the same dom::workers signaturre. Activities vary from watching 1080p youtube to sitting at a idle bugzilla tab. It crashed a few minutes ago when writing a comment at reddit. Is there a corrresponding Windows bug or is this restricted to macos?
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
idk why it did that. sorry
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
So far the crashes I see in the 2 signatures listed in this bug are both confined to MacOS 10.14.
Adding 66 as affected.
I forgot to add in the last comment that one crash has moz crash reason MOZ_CRASH(mozilla::detail::MutexImpl::mutexTryLock: pthread_mutex_trylock failed). There are also a few other signatures that have similar Moz crash reason, not sure if they are same issue as this bug or not: https://bit.ly/2A4ygDr.
One the signatures shows a 100 correlation to an addon called Night Eye:

(100.0% in signature vs 00.54% overall) Addon "Night Eye - Dark mode on any website" = true
(100.0% in signature vs 04.75% overall) Module "CoreHandwriting" = true
(100.0% in signature vs 04.75% overall) Module "Montreal" = true
(100.0% in signature vs 04.75% overall) Module "MetadataUtilities" = true
(100.0% in signature vs 04.75% overall) Module "AppleLDAP" = true
(100.0% in signature vs 04.75% overall) Module "XCTTargetBootstrap" = true

mb are you using that extension?
Flags: needinfo?(mb8672)
Hi Marcia, yes I am indeed using that particular extension. Unfortunate to hear that these crashes are related to Night Eye. Nifty little thing and the performance hit was not as bad as other dark-mode extensions.
Flags: needinfo?(mb8672)

Adding a related signature that showed up when triaging crashes.

Crash Signature: [@ mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] [@ mozilla::detail::MutexImpl::lock | mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] → [@ mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] [@ mozilla::detail::MutexImpl::lock | mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] [@ RtlAcquireSRWLockExclusive | mozilla::dom::WorkerDebuggerManager::RegisterDebug…

Adding another signature, and 67 as affected. Still a low volume crash likely related to the extension noted in Comment 8.

Crash Signature: mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread ] → mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread] [@ RtlpWakeConditionVariable | mozilla::dom::WorkerDebuggerManager::RegisterDebuggerMainThread]
You need to log in before you can comment on or make changes to this bug.