Closed Bug 151217 Opened 21 years ago Closed 21 years ago

buglist references the wrong priority field

Categories

(Bugzilla :: Query/Bug List, defect)

2.17
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Bugzilla 2.16

People

(Reporter: m, Assigned: gerv)

References

Details

(Keywords: regression)

Attachments

(1 file)

buglist.cgi (as downloaded from CVS today) contains a reference to the column
"priority" rather than "bugs.priority". This causes some problems on the bug
list page, e.g. an error if you try to edit multiple bugs.

This can be fixed by changing line 1340 of buglist.cgi from:

$order = "map_assigned_to.login_name, bugs.bug_status, priority, bugs.bug_id";

to:

$order = "map_assigned_to.login_name, bugs.bug_status, bugs.priority, bugs.bug_id";
Blocks: 150783
Attached patch Patch v.1Splinter Review
Patch as suggested. This can't possibly hurt, and makes the reference match the
one a few lines further down. I'd say this was an obvious fix.

Gerv
Comment on attachment 87425 [details] [diff] [review]
Patch v.1

r=bbaetz x2

2.14 had this too
Attachment #87425 - Flags: review+
Keywords: patch, review
Summary: Invalid column reference → buglist references the wrong priority field
Whiteboard: [applied to b.m.o]
Should this be in the branch as well? Did this regress from an earlier version?
If so, mark 2.16 on checkin, I'll set 2.18 for now.
Target Milestone: --- → Bugzilla 2.18
My 'it happens in 2.14.2' comment was a subtle hint that it happened in 2.14,
and doesn't break anything AFAIK, so 2.18 it is.
And my "earlier version" was a subtle hint that this might've regressed from
something even earlier :-) I'm fine with 2.18.
It does break things. E.g. for me (CVS 2.17 downloaded 2002-06-12), 'edit 
multiple bugs simultaneously' didn't work (returned an error relating to this). 
I had to apply this fix before I could get that feature to work.
Ah, ok, I see now. The ORDER sanity checking fails, because theres no . in the name.

->2.16, -> patch owner

We broke 2.14.2, too! Bleh. I'll patch that when I patch the other regression
Assignee: endico → gerv
Keywords: regression
Target Milestone: Bugzilla 2.18 → Bugzilla 2.16
What does not have . in the name?  Dave said he checked every column.
The column "priority" has no . in its name; it should be "bugs.priority". (i.e.
the point of this bug :-) )
mattyt: the preset query for Assign. It works intially, but then its set in the
cookie/QUERY_STRING, and fails in the future.
Checked in on trunk and 2.16 branch. What are we doing about 2.14.2? Do I need
to pull one of those and check in there too? Should this bug be closed?

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.169.2.10; previous revision: 1.169.2.9
done

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.178; previous revision: 1.177
done

Gerv
Theres a separate bug fixing this issue + the trim issue for 2.14.

You can mark this bug FIXED.
per comments.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
and just for the record, I wasn't the one who checked all the columns.  I don't
know who did, this all happened during one of the weeks when I wasn't around much.
Jun 06 13:37:59 <justdave>	I enabled every column in the change columns thing
and tried sorting on each of them
Whiteboard: [applied to b.m.o]
Verifying fixed.
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.