Closed Bug 1512303 Opened Last year Closed 11 months ago

[remote-dbg-next] Manifest URL link in about:debugging is not working

Categories

(DevTools :: about:debugging, defect, P1)

defect

Tracking

(firefox66 verified, firefox67 verified, firefox68 verified)

VERIFIED FIXED
Firefox 66
Tracking Status
firefox66 --- verified
firefox67 --- verified
firefox68 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STRs:
- go to about:debugging
- click on the manifest link for any extension

ER: The manifest opens in a new tab 
AR: A blank tab opens
Likewise, it seems that the links which specified `_blank` target on old `about:debugging`, `about:devtools` also do not work.
I suppose this is caused by our platform changes. (Perhaps, bug 1503681?)
This will be fixed if we add rel="opener" attribute to the <a> though, I don't know that we should consider to fix the platform.
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
Looks like the root issue is already fixed on the platform side! 

I am bisecting to find out when this was fixed to see if we should uplift anything. I will add a test in any case to avoid future regressions. Adding rel="noopener noreferrer" to our links would not hurt anyway.
This was fixed by Bug 1512311, I believe it will be uplifted, so no strong reason to create a temporary patch to uplift here.
See Also: → 1512311
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/327dfbe04cb4
Add test for manifest URL link in about:debugging;r=ladybenko
https://hg.mozilla.org/mozilla-central/rev/327dfbe04cb4
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

I have reproduced this bug with Nightly 65.0a1 (2018-12-05) on Windows 10, 64 Bit. The fix of this bug is verified with latest Beta 66.0b14!

Build ID 20190307095232
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

[bugday-20190313]

I've verified this issue on latest Nightly 68.0a1, Firefox dev edition 67.0, release 66.0.1 => on all versions the issue won't occur.
Additionally, I will add full STR's:
[Precondition]: The user must have an extension file downloaded on the PC.

  1. Open Firefox
  2. Go to about:debugging
  3. Click on "Load Temporary Add-on" button
  4. Select from your PC an extension file (previously downloaded)
  5. Click on "Manifest URL" link

then inspect if the manifest.json file in loaded correctly in a new tab.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.