Closed Bug 1512332 Opened 9 months ago Closed 9 months ago

Update focus ring acording to photon specs

Categories

(Toolkit :: Themes, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox65 --- wontfix
firefox66 --- fixed

People

(Reporter: Matthias, Assigned: Matthias)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

Everything (menulists etc) should have the blue focus shadow.
Priority: -- → P2
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f306a3db8b35
Photonized focusring for menulist etc. r=dao
Assignee: nobody → matthias
I'm sorry, but I have no idea how to fix this error and why it occurs =/
@dao, can you help me?
Flags: needinfo?(matthias) → needinfo?(dao+bmo)
The error message is:

Expected identifier for pseudo-class parameter but found ‘:’. Ruleset ignored due to bad selector.

The problem appears to be the chained pseudo-element selectors that CSS doesn't seem to allow:

html|input[type="color"]::-moz-number-spin-up::-moz-focus-inner,
html|input[type="number"]::-moz-number-spin-down::-moz-focus-inner

(There's also another typo in there... "color" should be "number".)
Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b02de5a5396b
Photonized focusring for menulist etc. r=dao
https://hg.mozilla.org/mozilla-central/rev/b02de5a5396b
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
No longer depends on: 1533055
Regressions: 1533055
You need to log in before you can comment on or make changes to this bug.