Nested transforms are not flattened with WebRender.

RESOLVED FIXED in Firefox 66

Status

()

defect
P2
normal
RESOLVED FIXED
6 months ago
3 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

(Blocks 1 bug)

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(4 attachments)

Posted file Testcase
We found this with the help of Matt this morning.
Assignee

Comment 1

6 months ago
Jeff, mind prioritizing it? I suspect it's P2 but let me know if not.
Flags: needinfo?(jmuizelaar)
Flags: needinfo?(emilio)
Assignee

Updated

6 months ago
Blocks: 1474294
Actually we might have a test case that covers this, we have bug 1496539 on file for fixing transform-style-flat-1a.html.
See Also: → 1496539
Assignee

Comment 3

6 months ago
That one looks different, as WR matches Blink here at least.
Flags: needinfo?(jmuizelaar)
Priority: -- → P2
Assignee

Updated

6 months ago
Flags: needinfo?(emilio)

Comment 7

6 months ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a0097b6b670
Let the reference frame know about the transform style. r=kats
https://hg.mozilla.org/integration/autoland/rev/f9f6c219680d
Update euclid. r=kats
https://hg.mozilla.org/integration/autoland/rev/cca0fa760d54
Update test expectations. r=kats
Duplicate of this bug: 1496539
Assignee

Updated

3 months ago
Blocks: 1533456

Hello everyone!
:emilio informed me via irc that this issue has regressed. The track of this regression is kept in bug 1533456.
Thank you!

You need to log in before you can comment on or make changes to this bug.