Closed Bug 1512585 Opened 4 years ago Closed 4 years ago

No search results displayed when Twitter is set as default search engine in Search toolbar

Categories

(Firefox :: Search, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr60 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix

People

(Reporter: mberlinger, Unassigned)

Details

Attachments

(1 file)

Attached image search toolbar.gif
[Affected versions]:
- 60.4.0esr
- 63.0.3
- 64.0b14
- 65.0a1 (BuildId: 20181206214149)

[Affected platforms]:
- Windows 7x64
- Windows 10x64
- Ubuntu 16.04x64
- macOS 10.13.6

[Steps to reproduce]:
1. Launch Firefox.
2. Enable the search bar from about:preferences#search by clicking on "Add search bar in toolbar" option.
3. Select Change search settings when the search drop-down panel is opened.
4. Set Twitter as default search engine.
5. Perform a search for a random keyword.

[Expected result]:
- Search results are displayed for that search term by the newly set default search provider.

[Actual result]:
- No search results displayed.

[Regression range]:
- I don't think it's a recent regression since I was able to reproduce it on Firefox 57.0.

[Additional notes]:
- see the attached screencast.
Our Twitter search plugin doesn't have a suggestions URL endpoint, and it looks like Twitter doesn't offer one, so this is as expected.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.