Closed Bug 15128 Opened 21 years ago Closed 21 years ago

Unable to change the text of XP menus

Categories

(Core :: XUL, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: hangas, Assigned: waterson)

References

Details

Windows XP menus do not support changing the text of a menu item from JavaScript.
The JavaScript changes the text on Mac, but on windows the text does not change.
The address book has code checked in the changes the text of the Delete menu item
in the Edit menu depending on the item that is currently selected (address book
vs. card).
Blocks: 15127
Please attach a test case. This works for everyone else. :)
You are doing setAttribute("value", "foo")... correct?
Yes, commandNode.setAttribute('value', value);
This works on the Mac.
I would like to look at a working example because waterson and I confirmed that
it was simply not working on Windows.  My test case is checked into the tree: go
to the address book, click on an address book and the text of the "Delete" menu
should change from 'Delete' to 'Delete Address Book'.  It does on the Mac but not
on Windows.
Assignee: saari → waterson
You left out a key piece of the puzzle... namely that you're using broadcasters.
 Reassigning to waterson, since this is not a problem with the menus but with
the broadcaster hookup.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
broadcaster stuff fixed. hangas: can you check it out?
QA Contact: beppe → paulmac
Unable to verify with code checked into tree.  It is possible that the text is
being changed but when attempting to change a menu item from "Detete" set to
disabled, to one set to "Delete Address Book" set to enabled, I get "Del..." set
to enabled.  I cannot confirm that it is working.  I need to file a new bug about
the menu not growing to allow for this longer text (assuming that it works).
Unable to verify at this time.
Status: RESOLVED → VERIFIED
OK, fix verified.  The menu text does change now.  I had to hack up a test to
confirm.  Marking verified.
You need to log in before you can comment on or make changes to this bug.