If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Child window opens behind parent on window.open()

RESOLVED DUPLICATE of bug 108394

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 108394
16 years ago
15 years ago

People

(Reporter: andy, Assigned: Dan M)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

when typing the following url in the url box, and hitting enter

javascript:window.open('http://car-part.com');document.href=document.location;

a new window pops up in the background, instead of as the frontmost, active window


in netscape 4.79, and explorer, that url will cause a new window to come up in
front, as the active window.

Reproducible: Always
Steps to Reproduce:
1.put javascript:window.open('http://car-part.com');document.href=document.location;
 in the url box
2.
3.

Comment 1

16 years ago
Browser, not engine. 

Confirming report using today's Mozilla trunk binary on WinNT. 
Exactly as the reporter states: the child window opens behind
the parent. 

Compare: in IE6, the child window opens in front. 
I'm going to send this one to danm, and the DOM Level 0 component.
cc'ing jst. 

maybespamforandy1@car-part.com: the javascript:URL you have given is
javascript:window.open('http://car-part.com');document.href=document.location;

But actually, just the first half of that is all we need to see 
the bug, right? Just the window.open() does it for me -

danm: sorry if this is a known issue
Assignee: rogerl → danm
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → desale
Summary: new window open does not work right → Child window opens behind parent on window.open()

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 108394 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.