Closed Bug 1513167 Opened 5 years ago Closed 4 years ago

Social media icons are broken on computerworld.com.br while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 66
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-social])

User Story

addtoany.com

Attachments

(2 files)

Attached image BrokenSocialMEdia.jpg
[Environment:]
Browser / Version: Firefox Nightly 65.0a1 (2018-12-10) 
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled (Custom > Tracker in all windows > Basic Block List).
[Steps to Reproduce:]
    1. Navigate to  https://computerworld.com.br/2018/07/06/novo-modelo-do-cmmi-traz-mais-beneficios-empresas-para-melhoria-nos-processos/ 
    2. Scroll down the page.
    3. Observe social media icons.
       
[Expected Behavior:]
Social media icons are displayed correctly.
 
[Actual Behavior:]
Social media icons are broken (large and text overlapping).
The issue is related to `Tracking Protection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://widgets.outbrain.com/outbrain.js” was blocked because content blocking is enabled.
The resource at “https://www.googletagservices.com/tag/js/gpt.js” was blocked because content blocking is enabled.
The resource at “https://www.googletagmanager.com/gtag/js?id=UA-125433852-1” was blocked because content blocking is enabled.
The resource at “https://widgets.outbrain.com/outbrain.js” was blocked because content blocking is enabled.
The resource at “https://static.addtoany.com/menu/page.js” was blocked because content blocking is enabled.

So below are the domains to test:
- ​widgets.outbrain.com
- ​www.googletagservices.com
- ​www.googletagmanager.com
- ​widgets.outbrain.com
- ​static.addtoany.com

I opened the URL in a fresh browser profile (Firefox Nightly 66, uMatrix installed, normal mode) and loaded the page. The social media icons are broken.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- addtoany.com (including all related domains)
and social media icons are correctly displayed.

The other resources didn't help. 

So in conclusion:
- addtoany.com is in Social category = [tp-social]
User Story: (updated)
Whiteboard: [tp-social]
Attached image uMatrixResults.jpg
Added uMatrix results.
Product: Tech Evangelism → Web Compatibility

The icons show up and seem to work fine for me even in strict mode now, so this seems fixed.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.