Closed Bug 1513256 Opened 8 months ago Closed 8 months ago

combobox dropdown is very slow when there are many options

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1118086
Tracking Status
firefox66 --- affected

People

(Reporter: bzbarsky, Unassigned)

Details

Attachments

(1 file)

Attached file Testcase
Please see the attached testcase.  It's based on the page linked in https://news.ycombinator.com/item?id=18620671 but is a lot more safe-for-work.  The actual page has 4974 items in the dropdown; my testcase has 4096, because that's simpler.

Profile shows lots of JS running under FireShowDropDownEvent (hundreds of ms worth!), but it's jitted, so I can't tell what the relevant scripts are offhand.

Mike, do you know who would know about this code and might have time to look at it?
Flags: needinfo?(mconley)
Hmm.  Maybe this is a dup of bug 1118086...
Sorry for the delay responding! Yes, I believe this is a dupe of bug 1118086.
Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1118086
You need to log in before you can comment on or make changes to this bug.