Firefox crashes when you merge titlebar and tab list

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 months ago
4 months ago

People

(Reporter: greatBigDot, Assigned: stransky)

Tracking

(Blocks 1 bug, {crash, regression, topcrash-linux})

64 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 wontfix, firefox65 wontfix, firefox66- wontfix)

Details

(crash signature, URL)

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

On Arch Linux with the XFCE4 window manager, simply go to the customization menu (Menu > Customize) and uncheck the "Title Bar" option.


Actual results:

Firefox immediately crashes. When reopened, the changes to the option in question are not saved.


Expected results:

Firefox should merge the tab bar and the titlebar, exactly how it did in v-63. Preferably, it would do this without immediately crashing.
(Reporter)

Updated

4 months ago
Blocks: gtktitlebar
Keywords: crash
(Reporter)

Updated

4 months ago
Crash Signature: libglib-2.0.so.0.5800.1@0x5a9b6
Crash Signature: libglib-2.0.so.0.5800.1@0x5a9b6 → [@ libglib-2.0.so.0.5800.1@0x5a9b6 ]
Component: Untriaged → Widget: Gtk
Keywords: regression
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
greatBigDot, can you share any Submitted Crash Report IDs listed in your about:crashes page?

Comment 3

4 months ago
I experienced the same issue and found that I could work around it by downgrading gtk3 3.24.1+155+g4c8fcd6a6f-1 to gtk3 3.24.1+8+g220f77d8c1-1.  I hope that's of some use in trouble-shooting this.
(Reporter)

Comment 4

4 months ago
Downgrading gtk3 worked for me too. Thanks @martinking!

Note: I said in the original post that the issue appeared after upgrading to v-64. While true, after downgrading back to v-63, the problem remained for me (even though I had no problems on v-63.0.3 yesterday). Apparently the Firefox update was completely coincidental... I'm not sure. Anyways, downgrading gtk3 makes it work on the current Firefox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Martin is is a bug that falls into your team bucket?
Flags: needinfo?(stransky)

Comment 6

4 months ago
Can confirm, after upgrading firefox it could not start even in safe mode. Arch Linux x86_64, XFCE. I had no issues before, had to refresh firefox to be able to launch it and as soon as I tried to remove the title bar it crashed every time:

https://crash-stats.mozilla.com/report/index/af1ed27c-35cb-4238-894a-297240181212
https://crash-stats.mozilla.com/report/index/49c4c8e9-b3bc-46c6-aa4c-388c20181212
https://crash-stats.mozilla.com/report/index/a4cc5b88-f465-4517-867e-97bb50181212

So upon reading your comments the real culprit is gtk3 upgrade and firefox has nothing to do with it?

Comment 7

4 months ago
This does appear to have been an issue with gtk3 and looks to have been fixed with the upgrade of gtk-update-icon-cache 3.24.1+155+g4c8fcd6a6f-1 -> 3.24.2+1+g2905fc861a-1 on Arch.

I'm not a developer so no team bucket.  I signed up just to add the gtk3 information.  Please let me know if it's not appropriate for me to be posting here and thanks for your help.
[Tracking Requested - why for this release]: This is the top crash on Linux for the 12-14 Nightly, with 43% of all Linux crashes.
(Assignee)

Comment 9

4 months ago
(In reply to Pascal Chevrel:pascalc from comment #5)
> Martin is is a bug that falls into your team bucket?

Yes I'll look at it.
Assignee: nobody → stransky
(Assignee)

Comment 10

4 months ago
Can anyone reproduce that on something else than Arch Linux? I tried XFCE on Fedora, both accelerated/non-accelerated windows without any luck. I have the gtk-update-icon-cache-3.24.1 package installed.

Link to Arch report: https://bugs.archlinux.org/task/61050

so looks like Arch specific and already fixed there.
Flags: needinfo?(stransky)
Closing based on the Arch Linux report.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.