Closed Bug 15138 Opened 20 years ago Closed 20 years ago

Display current state for editor toolbar font face & size

Categories

(Core :: Editor, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 18395

People

(Reporter: michael.j.lowe, Assigned: cmanske)

References

Details

The font and size popup menus should reflect the current font and size
attributes of the text at the current cursor location, much as the paragraph
popup currently does.
Assignee: buster → cmanske
Status: NEW → ASSIGNED
Target Milestone: M11
The UE team (German) suggested that a widget that shows state should use the
HTML select (size="1") "dropdown list" widget. When the CSS is working for the
select widget, it will not have the white background (it will inherit the
toolbar background), so it won't be as ugly as it used to be (which is why we
explored using a titled button instead).
Target Milestone: M11 → M12
Summary: Editor toolbar font & size popup menus → Display current state for editor toolbar font face & size
Improved summary.
Depends on: 18395
Target Milestone: M12 → M13
We need to move all of our UI state notification from core editor to JavaScript
Fixing this bug depends on that work.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This issue is covered well enough by 18395. We may share the work in
implementing this, but I don't think we need more than one tracking bug.

*** This bug has been marked as a duplicate of 18395 ***
Status: RESOLVED → VERIFIED
verified in 12/20 build.
You need to log in before you can comment on or make changes to this bug.