Google-URL duplicates substring "start=0"

RESOLVED WORKSFORME

Status

SeaMonkey
Search
--
trivial
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: Christophe Thalet, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
build 2002053012

when searching with google from the typed URL bar,
the query string that is sent to google contains 2 times
"start=0"
(Reporter)

Comment 1

16 years ago
(reproduction:

type (including the quotes)
"foo bar"
in the URL bar, when the dropdown option for searching with google appears,
click it

Comment 2

16 years ago
the google URLs do indeed seem to end up with two start=0 arguments.  doesn't
hurt anything much though.  confirming.
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
From google.src

>   update="http://www.google.com/mozilla/google.src"

It seems like google created the google-plugin?!
..maybe someone should drop google a mail?

Comment 4

15 years ago
On the issue of the value being placed in the URL twice.  In testing, if the
"name" is the same for both, one only needs to define inputnext.  Inputprev will
assume the the same name and factor.  From AltaVista.src for example:

<inputnext name="stq" factor="10">
<inputprev>

NOTE: The <inputprev> still needs to be there or the "Previous" button will be
disabled.

Using similar code in your Google plugin should remove the annoyance without any
adverse affects.

Unless Apple Sherlock handles this differently or we can find a test case that
fails we most likely will get a won't fix.  

Does Apple handle this the same way?  

Comment 5

15 years ago
The inputnext and inputprev tags are unique to mozilla's implementation of sherlock.

I'm not sure what apple's UI for retrieving subsequent results is.
I'll look into it.

Sam

Updated

15 years ago
Depends on: 172119

Updated

15 years ago
Blocks: 172119
No longer depends on: 172119

Comment 6

11 years ago
This bug is still present in SeaMonkey 1.1:
Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.1.2pre) Gecko/20070119 SeaMonkey/1.1
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: samir_bugzilla → nobody
QA Contact: claudius → search

Comment 7

6 years ago
WORKSFORME:
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120705175350

Probably because these days we are now using OpenSearch and not Sherlock.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.