Crash in java.lang.NoSuchMethodError: at org.mozilla.gecko.SpeechSynthesisService$2.run(SpeechSynthesisService.java)

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
critical
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: marcia, Assigned: eeejay)

Tracking

({crash, regression})

Trunk
mozilla66
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64+ fixed, firefox65+ verified, firefox66+ verified)

Details

(crash signature)

Attachments

(2 attachments)

This bug was filed from the Socorro interface and is
report bp-2fb786f1-eb98-4455-9005-d07cc0181212.
=============================================================

Seen while looking at crash stats: https://bit.ly/2PAzT0d. This particular crash seems higher on 64.0b15 than on 63.0.2 release. Seems to be API 16 (Jelly Bean only) crash.

There is another higher volume signature, https://bit.ly/2rIxyXX, which are non Jelly Bean crashes and APIs range from 28 down.

Some comments mention crashing while reading Yahoo news, but the URLs are quite varied.

Java stack trace:

java.lang.NoSuchMethodError
	at org.mozilla.gecko.SpeechSynthesisService$2.run(SpeechSynthesisService.java:56)
	at android.os.Handler.handleCallback(Handler.java:615)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:43)
Crash Signature: [@ java.lang.NoSuchMethodError: at org.mozilla.gecko.SpeechSynthesisService$2.run(SpeechSynthesisService.java)] → [@ java.lang.NoSuchMethodError: at org.mozilla.gecko.SpeechSynthesisService$2.run(SpeechSynthesisService.java)] [@ java.lang.NullPointerException: at org.mozilla.gecko.SpeechSynthesisService$2.run(SpeechSynthesisService.java) ]
ISTR another Fennec crash in the past involving speech which ended up being related to ads being served?
Susheel, what should we do here?
Flags: needinfo?(sdaswani)

Comment 3

6 months ago
Seems like a gecko issue given the stack trace? Snorp or DB can you advise?
Flags: needinfo?(snorp)
Flags: needinfo?(sdaswani)
Flags: needinfo?(dbolter)
This might be Eitan's area.
Flags: needinfo?(dbolter) → needinfo?(eitan)
I think the NoSuchMethodError exception was resolved with bug 1510611.

As for the NullPointerException, I can post a patch here.
Flags: needinfo?(eitan)
I doubt we want to backport all of bug 1510611, but would it be worth extracting out the relevant bits for an uplift patch here?
Assignee: nobody → eitan
Flags: needinfo?(eitan)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> I doubt we want to backport all of bug 1510611, but would it be worth
> extracting out the relevant bits for an uplift patch here?

Sure.
Flags: needinfo?(eitan)
This will be the patch we should ultimately uplift to beta.
Looks like Eitan has this under control.
Flags: needinfo?(snorp)

Comment 11

6 months ago
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f98a1c651b3
Null check return from TextToSpeech.getFeatures() r=agi

Comment 12

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2f98a1c651b3
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Can you request uplift to beta, and possibly to mozilla-release as well? 
Thanks!
Flags: needinfo?(eitan)
We may want to consider this as a ride-along in case we have a 64 dot release.
Comment on attachment 9032827 [details] [diff] [review]
Null check return from TextToSpeech.getFeatures() r?agi!

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Some crashing when web speech API is invoked.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It's been verified on nightly and it's pretty straightforward.

String changes made/needed:
Flags: needinfo?(eitan)
Attachment #9032827 - Flags: approval-mozilla-release?
Attachment #9032827 - Flags: approval-mozilla-beta?
Comment on attachment 9032827 [details] [diff] [review]
Null check return from TextToSpeech.getFeatures() r?agi!

[Triage Comment]
Fixes some crashes with the Web Speech API. Approved for 65.0b7.
Attachment #9032827 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Priority: -- → P1
Crashes are gone in 65.0b7 \m/
Status: RESOLVED → VERIFIED

Comment on attachment 9032827 [details] [diff] [review]
Null check return from TextToSpeech.getFeatures() r?agi!

fix for #5 top crash for fennec 64.0.1, verified in 65b, approved for 64.0.2

Attachment #9032827 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.