Closed Bug 1513925 Opened 2 years ago Closed 2 years ago

Crash in nsWebBrowserFind::SearchInFrame

Categories

(Core :: DOM: Core & HTML, defect)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1510485
Tracking Status
firefox64 --- unaffected
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-202af487-c3b4-48c1-84f1-10cc10181204.
=============================================================

Mac crash which started back in the 65 nightly timeframe: https://bit.ly/2Bf9XT1. Not seen on other branches. First build seen is 20181127220131. 

Comments mention using https://addons.mozilla.org/en-US/firefox/addon/vim-vixen/ or Vimium to navigate the page. 

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=14ae1910a4f5dd1cdea7fcb4855a3aa86ed3731b&tochange=204cda7581188cfc8c8ef11dce4680dadf2b43bb

Comments mention using 

Top 10 frames of crashing thread:

0 XUL nsWebBrowserFind::SearchInFrame dom/base/nsINode.h:1593
1 XUL nsWebBrowserFind::FindNext toolkit/components/find/nsWebBrowserFind.cpp:112
2 XUL nsGlobalWindowOuter::FindOuter dom/base/nsGlobalWindowOuter.cpp:6482
3 XUL mozilla::dom::Window_Binding::find dom/base/nsGlobalWindowInner.cpp:4300
4 XUL bool mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::MaybeGlobalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3376
5 XUL js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:468
6 XUL Interpret js/src/vm/Interpreter.cpp:620
7 XUL js::RunScript js/src/vm/Interpreter.cpp:447
8 XUL js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:587
9 XUL JS::Call js/src/vm/Interpreter.cpp:634

=============================================================
Might be a different signature for bug 1510485... Sounds pretty likely actually, given that one only has Linux or Windows signatures.
Duping to Bug 1510485 - it looks as if it is the mac variant of that crash and there are no further crashes after the patch landed to fix that bug.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1510485
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.