Open Bug 1514168 Opened 2 years ago Updated 1 year ago

"Set a homepage" is not working for the first tab

Categories

(Firefox for Android :: Settings and Preferences, defect, P3)

Firefox 64
ARM
Android
defect

Tracking

()

REOPENED
Tracking Status
firefox-esr68 --- affected
firefox64 --- affected
firefox65 --- unaffected
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fix-optional
firefox70 --- fix-optional

People

(Reporter: mirabela.lobontiu, Assigned: andrei.a.lazar)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached video 2018_12_14_05_33_58.mp4
Device:
 - Samsung Galaxy Tab S3 (Android 8.0);

Build:
 - Release 64.0.1;

Steps to reproduce:
 1. Go to Settings -> General -> Home -> Set a homepage and select "Custom".
 2. Type a random word or a link -> OK. 
 3. Enable the "Also use for new tabs".
 4. Close all opened tabs and close Firefox, then reopen it.

Expected result:
 The homepage should be the link set on step 2 or a search through the default search engine with the word/text entered at step 2.

Actual result:
 The default homepage is displayed. The second tab opened displays correctly the link/text from step 2. If all tabs are closed, the new tab also displays correctly the link/text from step 2.

Notes:
 - Not reproducible on Nightly 66.0a1 (2018-12-13), nor Beta 65.0b4.
 - Reproducible even if Settings -> General -> "Also use for new tabs" is not enabled.
 - Reproducible with Settings -> Advanced -> Restore tabs -> "Always restore" enabled and with "Don`t restore after quitting" enabled.

Please see the attached video.
Not reproducible on:
- Xiaomi Redmi Note 3 (Android 6.0.1)
- Lenovo A536 (Android 4.4.2)
- Sony Xperia Z2 (Android 6.0.1)
- Google Pixel C (Android 8.0.0)
- Sony Xperia Z5 (Android 7.0)
Assignee: nobody → andrei.a.lazar
I could not reproduce the issue anymore, using the same device, Samsung Galaxy Tab S3 (Android 8.0).
I will close this issue as WORKSFORME.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME

Hi,

I reopened this issue because I was able to reproduce it on Beta 67.0b3, and Nightly 68.0a1 (2019-03-18), using Samsung Galaxy Note 8 (Android 9.0), and Samsung Galaxy Tab S3 (Android 8.0).

The STR were:

  1. Go to Settings -> General -> Home -> Set a homepage and select "Custom".
  2. Type a random word (i.e. "a") -> OK.
  3. Close all opened tabs and Firefox.
  4. Reopen Firefox.

Actual result:
Firefox opened a page with the "Server not found" message.

Status: RESOLVED → REOPENED
Has STR: --- → yes
Resolution: WORKSFORME → ---

Note: if a link is typed at step 2, everything works as expected.

Priority: -- → P3

This is reproducible even if "Also use for new tabs" is not enabled. The page is in loading mode and tapping on "X" shows a white page and URL.

Device: Xiaomi Mi4i (Android 5.0.2).
Build: 67.0b5.

I reproduce the issue from Comment 3 on device Huawei MediaPad M3 Lite10(Android 7.0) on Firefox Nightly 68.0a1(2019-07-01)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Hi! This is reproducible on Beta 68.1b1, Nightly 69.0a1 (2019-07-08) with Samsung Galaxy Tab S3 (Android 8).

Duplicate of this bug: 1563921

Setting fix-optional to take this out of weekly triage.
Happy to take a patch for 70 or beyond.

You need to log in before you can comment on or make changes to this bug.