Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 151422 - Microsoft Outlook Web Access won't log in
: Microsoft Outlook Web Access won't log in
Status: RESOLVED DUPLICATE of bug 23679
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Matthias Versen [:Matti]
: imajes - QA account - use instead
Depends on:
  Show dependency treegraph
Reported: 2002-06-12 21:24 PDT by Doug Bish
Modified: 2004-11-22 17:25 PST (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Doug Bish 2002-06-12 21:24:59 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

My company e-mail access is through Microsoft Outlook Web Access for Microsoft
Exchange Server. The initial entry page loads and asks for my alias. After the
alias is entered, I should get a login box asking for by user ID, password, and
domain. Instead I get a white screen.

Reproducible: Always
Steps to Reproduce:
1.You'll need an Exchange Server set up for web access to test. Using my login
would give you access to my corporare exchange server.
2.Log into the exchange server using
3.Enter your alias. enter key or click on the click here link.

Actual Results:  The login screen never comes back. The browser displays a white

Expected Results:  Mozilla should return a login screen requesting User ID,
Password, and Domain Name.

AOL browsers also have this problem. Haven't tried Netscape. I'm hoping it's not
an issue where Microsoft won't give you the ability to access Exchange through
any browser except theirs.
Comment 1 Greg K. 2002-06-13 12:11:22 PDT
Doug, is it attempting to access an https:// URL, by any chance?
Comment 2 Greg K. 2002-06-13 23:52:36 PDT
Possibly a duplicate of bug 23679.
Comment 3 Doug Bish 2002-06-14 00:27:17 PDT

No, it is not accessing an https:// URL. It's accessing an URL named http:/
/ Since you don't have my access, you 
could try this URL to at least geta view of the entry page if it helps.

Comment 4 WD 2002-06-14 15:10:25 PDT
re: comment #2
I do not think so, as OWA supports Netscape.
Comment 5 Matthias Versen [:Matti] 2002-06-14 15:20:35 PDT
we need a packet trace to see if the server wants NTLM for the authentification.
But it reall looks like that the problem is NTLM because you get a domain field.

Reporter: Can you try to generate a networking log ?
I dunno if this works, never tried it on Mac.
Please try to login and after you failed close Mozilla and atatch the log to
this bug.

On Mac:
Create a text file that contains the desired commands in a text editor such as
ARGS: -mail (Only if you want to Log Mail&News)

Save this file and drag and drop this file on the Netscape/Mozilla application icon.
The log file is created in the seamonkey folder.
Comment 6 Keith Briscoe 2002-06-15 11:20:58 PDT
This may be obvious, but having set up Outlook Web Access in the past, I thought
I'd mention it.  Outlook Web Access can be set to use HTTP Basic Authentication,
NTLM Authentication, or both/either.  The setup screen muddies the waters a bit
by showing the options as "Basic Authentication" or "Secure Authentication".

Any admin not very versed in Microsoft Newspeak (tm) could easily set their
server up for secure authentication only, figuring that it's more secure.

If so, bugs here could be very server-specific.  I personally know Moz had no
issues with Basic Authentication the last time I had to use Outlook Web Access.
 Another big question would be whether Outlook handles the Basic+Secure setting
correctly.  I don't have the server to test this out with anymore, unfortunately.
Comment 7 Greg K. 2002-06-16 01:12:59 PDT
Since accessing the URL and trying to log in using IE results in an
authentication dialog featuring a Microsoft logo, that server is probably
configured to use NTLM rather than basic auth.
Comment 8 WD 2002-06-16 07:40:48 PDT
HTTP/1.1 401 Unauthorized
Date: Sun, 16 Jun 2002 14:39:29 GMT
WWW-Authenticate: NTLM
Connection: Keep-Alive
Content-Length: 0
Content-Type: text/html
Cache-control: private
Comment 9 Matthias Versen [:Matti] 2002-06-16 10:56:43 PDT
WWW-Authenticate: NTLM

*** This bug has been marked as a duplicate of 23679 ***

Note You need to log in before you can comment on or make changes to this bug.