Mozilla cannot FTP to servers located on an OpenVMS system

RESOLVED FIXED

Status

()

Core
Networking: FTP
--
major
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: Jouk Jansen, Assigned: Colin Blake)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; OpenVMS Digital_Personal_WorkStation_; en-US;
rv:1.0.0) Gecko/20020530
BuildID:    

An FTP-server located on an OpenVMS server cannot be accessed

Reproducible: Always
Steps to Reproduce:
1.FTP://openvmsserver
2.
3.

Actual Results:  Error message

Expected Results:  File transfer
(Assignee)

Comment 1

16 years ago
I guess I get the honor of working on this one...
Assignee: bbaetz → colin
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Isn't this dupe of bug 22299 ?
Yes. Colin, I thought you'd fixed that. I'm not going to be able to touch moz
stuff til Tuesday at the very earliest.

*** This bug has been marked as a duplicate of 22299 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

16 years ago
Bug 22299 is really about publish (via FTP) support, while this is about remote
browsing (via FTP). Two different pieces of code, I believe.

Comment 5

16 years ago
Oh. I thought that bug was about getting all basic VMS interop going...

Well, you own the bug, so if you want to fix browsing a directory here, then you
can reopen, if not, then please mark this VERIFIED/DUPE.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 6

16 years ago
I do plan on getting FTP directory support working at some point, so I'd like to
keep this bug open.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

15 years ago
This is in 1.5 (beta onwards). Marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED

Comment 8

14 years ago
Can this be re-opened to add support for OpenVMS ODS-5 volumes? As of Mozilla
1.7 this only appears to be fixed for ODS-2 volumes.
(Assignee)

Comment 9

14 years ago
I would suggest that you open a new bug report for the ODS-5 issue, though to be
honest, none of Mozilla behaves too well with ODS-5 volumes. When you enter the
new bug, please report exactly what the error is (do you see an error message?)
and which IP stack and version is running on the server.
You need to log in before you can comment on or make changes to this bug.