accept non-utm params in osx attributions

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Tracking

(Blocks 1 bug)

65 Branch
Firefox 66
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox65 fixed, firefox66 verified)

Details

Attachments

(1 attachment)

Based on bug 1511104 comment 10, it is unlikely we can get utm params passed through our web properties, but we could strip the "utm" part of the param name and make it work that way.  However, the attribution code needs to accept either to make that work.
I see that these changes are in an OSX-specific block. 

This is not the first time we have wished that we could pass some specific attribution parameters to a download. For example, imagine a scenario where we want to specifically segment some set of clients for a download or install experiment, so we want to put a variation into their attribution fields at the point of download. The issues raised in bug 1511104 comment 10 would make doing so troublesome. If we could do this with "utm-free" parameters as this patch allows, that would be great.

Is it possible this patch's scope could be widened slightly to allow the "utm-free" parameters to work for attribution regardless of OS?
(In reply to Justin Crawford [:hoosteeno] [:jcrawford] from comment #2)

> Is it possible this patch's scope could be widened slightly to allow the
> "utm-free" parameters to work for attribution regardless of OS?

Since this will require uplift to 65, I'd prefer to minimize the change to what is necessary.  I'd be happy to do a followup bug for windows that we could land in 66.
We could also expand this to take params other than just the source|medium|campaign|content for non-utm params if you feel that would really be useful, but again, a followup bug.
No longer blocks: 1515172
See Also: → 1515172
Pushed by mixedpuppy@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fc056f8fe673
make osx attributions work with both utm and plain params, r=mossop
https://hg.mozilla.org/mozilla-central/rev/fc056f8fe673
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Comment on attachment 9032227 [details]
Bug 1515153 - make osx attributions work with both utm and plain params, r?Mossop

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Attributions will not work on OSX, resulting also in Return to AMO/recommendations not working.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: A full set of QE tests are outlined in bug 1511071

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): covered by automated tests, minimal impact if anything were to go wrong which would only result in return to amo not working on osx, resulting in different content being shown to the user.

String changes made/needed: none
Attachment #9032227 - Flags: approval-mozilla-beta?
Comment on attachment 9032227 [details]
Bug 1515153 - make osx attributions work with both utm and plain params, r?Mossop

[Triage Comment]
Fixes broken attributions on OSX. While Return to AMO isn't shipping in 65 at this point, Shell tells me this is still important to take. Thanks for including a test. Approved for 65.0b7.
Attachment #9032227 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified altogether with the attribution system, no issues have been found on MacOS 10.13.6 using Nightly 66.0a1.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.