47 bytes, text/x-phabricator-request
|Details | Review|
There are a few entities names in the code that are not particularly good atm, mostly because the yare not consistent. 1. match VS result: the model uses match/matches, the view/controller use result/results. We should pick one. No particular preference here, I picked matches in the model mostly because one may think to "result" as the collection of all the matches, but in the end it doesn't really matter, consistency wins. 2. openpage VS tab: tab is imo clearer, but there's a couple exceptions where we can't change openpage, like the suggest.openpage pref. 3. addToUrlbarHistory is a poor choice, because the function just marks the next visit as typed. 4. UrlbarUtils may probably be renamed to UrlbarCommon considered it's not just a collection of utils, it also has common classes and constants. This is not particularly important anyway.
Assignee: nobody → dao+bmo
Summary: Name entities more consistently → Rename UrlbarMatch to UrlbarResult
Pushed by firstname.lastname@example.org: https://hg.mozilla.org/integration/autoland/rev/0aa259de1b77 Rename UrlbarMatch to UrlbarResult. r=mak
You need to log in before you can comment on or make changes to this bug.