Closed Bug 1515497 Opened 11 months ago Closed 7 months ago

Intermittent Assertion failure: rddOpened, at z:/build/build/src/dom/ipc/ContentParent.cpp:2620

Categories

(Core :: Audio/Video: Playback, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mjf)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: assertion, intermittent-failure)

Attachments

(2 files)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=217980688&repo=autoland

https://queue.taskcluster.net/v1/task/RE1I-kxOTCqG5dVpxiOP8A/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/RE1I-kxOTCqG5dVpxiOP8A/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

21:16:00     INFO - REFTEST TEST-START | file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1.html == file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1-ref.html
21:16:00     INFO - REFTEST TEST-LOAD | file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1.html | 43 / 44 (97%)
21:16:00     INFO - ++DOMWINDOW == 36 (095AC800) [pid = 5428] [serial = 136] [outer = 01271A80]
21:16:00     INFO - REFTEST TEST-LOAD | file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1-ref.html | 43 / 44 (97%)
21:16:00     INFO - ++DOMWINDOW == 37 (082F1800) [pid = 5428] [serial = 137] [outer = 01271A80]
21:16:00     INFO - REFTEST TEST-PASS | file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1.html == file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1-ref.html | image comparison, max difference: 0, number of differing pixels: 0
21:16:00     INFO - REFTEST TEST-END | file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1.html == file:///Z:/task_1545252220/build/tests/reftest/tests/layout/reftests/table-dom/insertTbodyRebuild1-ref.html
21:16:00     INFO - ++DOMWINDOW == 38 (0A671000) [pid = 5428] [serial = 138] [outer = 01271A80]
21:16:11     INFO - Assertion failure: rddOpened, at z:/build/build/src/dom/ipc/ContentParent.cpp:2620
21:16:41     INFO - #01: static class RefPtr<mozilla::MozPromise<RefPtr<mozilla::dom::ContentParent>,mozilla::ipc::GeckoChildProcessHost::LaunchError,0> > mozilla::dom::ContentParent::LaunchSubprocessInternal::<unnamed-tag>::operator()(void *) [dom/ipc/ContentParent.cpp:2255]
21:16:41     INFO - 
21:16:41     INFO - #02: mozilla::dom::ContentParent::LaunchSubprocessInternal(mozilla::hal::ProcessPriority,mozilla::Variant<bool *,RefPtr<mozilla::MozPromise<RefPtr<mozilla::dom::ContentParent>,mozilla::ipc::GeckoChildProcessHost::LaunchError,0> > *> &&) [dom/ipc/ContentParent.cpp:2292]
21:16:41     INFO - 
21:16:41     INFO - #03: mozilla::dom::ContentParent::GetNewOrUsedBrowserProcess(mozilla::dom::Element *,nsTSubstring<char16_t> const &,mozilla::hal::ProcessPriority,mozilla::dom::ContentParent *,bool) [dom/ipc/ContentParent.cpp:872]
21:16:41     INFO - 
21:16:41     INFO - #04: mozilla::dom::ContentParent::CreateBrowser(mozilla::dom::TabContext const &,mozilla::dom::Element *,mozilla::dom::ContentParent *,mozilla::dom::TabParent *,unsigned __int64) [dom/ipc/ContentParent.cpp:1178]
21:16:41     INFO - 
21:16:41     INFO - #05: nsFrameLoader::TryRemoteBrowser() [dom/base/nsFrameLoader.cpp:2510]
21:16:41     INFO - 
21:16:41     INFO - #06: nsFrameLoader::ShowRemoteFrame(mozilla::gfx::IntSizeTyped<mozilla::ScreenPixel> const &,nsSubDocumentFrame *) [dom/base/nsFrameLoader.cpp:798]
21:16:41     INFO - 
21:16:41     INFO - #07: nsFrameLoader::Show(int,int,int,int,nsSubDocumentFrame *) [dom/base/nsFrameLoader.cpp:664]
21:16:41     INFO - 
21:16:41     INFO - #08: nsSubDocumentFrame::ShowViewer() [layout/generic/nsSubDocumentFrame.cpp:175]
21:16:41     INFO - 
21:16:41     INFO - #09: AsyncFrameInit::Run() [layout/generic/nsSubDocumentFrame.cpp:90]
21:16:41     INFO - 
21:16:41     INFO - #10: nsContentUtils::RemoveScriptBlocker() [dom/base/nsContentUtils.cpp:5198]
21:16:41     INFO - 
21:16:41     INFO - #11: nsDocument::EndUpdate() [dom/base/nsDocument.cpp:4710]
21:16:41     INFO - 
21:16:41     INFO - #12: nsHTMLDocument::EndUpdate() [dom/html/nsHTMLDocument.cpp:2023]
21:16:41     INFO - 
21:16:41     INFO - #13: nsINode::ReplaceOrInsertBefore(bool,nsINode *,nsINode *,mozilla::ErrorResult &) [dom/base/nsINode.cpp:2404]
21:16:41     INFO - 
21:16:41     INFO - #14: static bool mozilla::dom::Node_Binding::appendChild(struct JSContext *, class JS::Handle<JSObject *>, class nsINode *, const class JSJitMethodCallArgs & const) [s3:gecko-generated-sources:b8e76d476df560a89f70b6a382606657fb63478ccdaf8da9a238cce3a5c2507e51beebdb05e150e2f7e9eecf792111a9a83a4eb01afac74ea5f0510e948c0330/dom/bindings/NodeBinding.cpp::1019]
21:16:41     INFO - 
21:16:41     INFO - #15: mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy,mozilla::dom::binding_detail::ThrowExceptions>(JSContext *,unsigned int,JS::Value *) [dom/bindings/BindingUtils.cpp:3064]
21:16:41     INFO - 
21:16:41     INFO - #16: CallJSNative(JSContext *,bool (*)(JSContext *,unsigned int,JS::Value *),JS::CallArgs const &) [js/src/vm/Interpreter.cpp:443]
21:16:41     INFO - 
21:16:41     INFO - #17: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:535]
21:16:41     INFO - 
21:16:41     INFO - #18: static bool InternalCall(struct JSContext *, const class js::AnyInvokeArgs & const) [js/src/vm/Interpreter.cpp:590]
21:16:41     INFO - 
21:16:41     INFO - #19: js::Call(JSContext *,JS::Handle<JS::Value>,JS::Handle<JS::Value>,js::AnyInvokeArgs const &,JS::MutableHandle<JS::Value>) [js/src/vm/Interpreter.cpp:606]
21:16:41     INFO - 
21:16:41     INFO - #20: js::ForwardingProxyHandler::call(JSContext *,JS::Handle<JSObject *>,JS::CallArgs const &) [js/src/proxy/Wrapper.cpp:162]
Blocks: 1471535
Component: DOM: Content Processes → Audio/Video: Playback

This is probably no longer valid since we're launching the RDD process on demand instead of at startup. The assert referenced (ContentParent.cpp:2620) no longer exists.

Hi Michael, if that's the case then there shouldn't be any other failures, right?

There are 31 total failures in the last 7 days on windows10-64 and windows10-64qr debug.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=226058592&repo=mozilla-inbound&lineNumber=6556

00:04:39 INFO - TEST-START | dom/media/test/test_playback.html
00:04:39 INFO - GECKO(8548) | ++DOMWINDOW == 12 (000001B861963400) [pid = 7256] [serial = 767] [outer = 000001B861F7E800]
00:04:39 INFO - GECKO(8548) | ++DOCSHELL 000001B85FCDC000 == 4 [pid = 7256] [id = {3b61082b-9de8-4587-b835-e1d0dab4a067}]
00:04:39 INFO - GECKO(8548) | ++DOMWINDOW == 13 (000001B862D42000) [pid = 7256] [serial = 768] [outer = 0000000000000000]
00:04:39 INFO - GECKO(8548) | ++DOMWINDOW == 14 (000001B862D42400) [pid = 7256] [serial = 769] [outer = 000001B862D42000]
00:04:52 INFO - GECKO(8548) | --DOCSHELL 000001B85FD9D800 == 3 [pid = 7256] [id = {9f51d8bf-3072-4e0f-aa27-cd7ba74b96c6}]
00:04:52 INFO - GECKO(8548) | --DOMWINDOW == 13 (000001B862D41800) [pid = 7256] [serial = 764] [outer = 0000000000000000] [url = about:blank]
00:04:58 INFO - GECKO(8548) | --DOMWINDOW == 12 (000001B862D43000) [pid = 7256] [serial = 765] [outer = 0000000000000000] [url = about:blank]
00:04:58 INFO - GECKO(8548) | --DOMWINDOW == 11 (000001B85FD52400) [pid = 7256] [serial = 766] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
00:04:58 INFO - GECKO(8548) | --DOMWINDOW == 10 (000001B85FD55000) [pid = 7256] [serial = 763] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/media/test/test_play_twice.html]
00:05:42 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mIsPending) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 8985
00:05:42 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mIsPending) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 8985
00:05:45 INFO - GECKO(8548) | [Parent 8984, StreamTrans #119] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/modules/libjar/nsJARChannel.cpp, line 372
00:05:45 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/modules/libjar/nsJARChannel.cpp, line 1010
00:05:45 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 126
00:05:45 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/netwerk/url-classifier/AsyncUrlChannelClassifier.cpp, line 756
00:05:48 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mSuspendCount > 0) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 9026
00:05:48 INFO - GECKO(8548) | [Child 7256, MediaPlayback #2] WARNING: NS_ENSURE_TRUE(SUCCEEDED(hr)) failed: file z:/build/build/src/dom/media/platforms/wmf/WMFUtils.cpp, line 71
00:05:48 INFO - GECKO(8548) | [Child 7256, MediaPlayback #4] WARNING: NS_ENSURE_TRUE(SUCCEEDED(hr)) failed: file z:/build/build/src/dom/media/platforms/wmf/WMFUtils.cpp, line 71
00:05:54 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mIsPending) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 8985
00:05:55 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mSuspendCount > 0) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 9026
00:05:59 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mSuspendCount > 0) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 9026
00:05:59 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mIsPending) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 8985
00:06:10 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: NS_ENSURE_TRUE(mSuspendCount > 0) failed: file z:/build/build/src/netwerk/protocol/http/nsHttpChannel.cpp, line 9026
00:06:11 INFO - GECKO(8548) | [Child 7256, MediaPDecoder #4] WARNING: Unimplemented function NotifyDataArrived: file z:/build/build/src/dom/media/mp3/MP3Demuxer.cpp, line 72
00:06:13 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 126
00:06:13 INFO - GECKO(8548) | [Parent 8984, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/netwerk/url-classifier/AsyncUrlChannelClassifier.cpp, line 756
00:06:14 INFO - GECKO(8548) | [Child 7256, MediaPDecoder #2] WARNING: Unimplemented function NotifyDataArrived: file z:/build/build/src/dom/media/mp3/MP3Demuxer.cpp, line 72
00:06:17 INFO - GECKO(8548) | [Child 7256, MediaPDecoder #2] WARNING: Unimplemented function NotifyDataArrived: file z:/build/build/src/dom/media/mp3/MP3Demuxer.cpp, line 72
00:06:18 INFO - GECKO(8548) | [Child 7256, MediaPDecoder #1] WARNING: Unimplemented function NotifyDataArrived: file z:/build/build/src/dom/media/mp3/MP3Demuxer.cpp, line 72
00:06:19 INFO - GECKO(8548) | [Child 7256, MediaPDecoder #2] WARNING: Unimplemented function NotifyDataArrived: file z:/build/build/src/dom/media/mp3/MP3Demuxer.cpp, line 72
00:06:33 INFO - GECKO(8548) | Assertion failure: rddOpened, at z:/build/build/src/dom/ipc/ContentParent.cpp:1134
00:06:52 INFO - GECKO(8548) | #01: mozilla::ipc::MessageChannel::DispatchSyncMessage(IPC::Message const &,IPC::Message * &) [ipc/glue/MessageChannel.cpp:2120]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #02: mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message &&) [ipc/glue/MessageChannel.cpp:2073]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #03: mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask &) [ipc/glue/MessageChannel.cpp:1937]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #04: mozilla::ipc::MessageChannel::MessageTask::Run() [ipc/glue/MessageChannel.cpp:1969]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #05: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1149]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #06: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:474]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #07: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:88]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #08: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:309]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #09: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #10: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:139]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #11: nsAppShell::Run() [widget/windows/nsAppShell.cpp:411]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #12: nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:272]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #13: XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4699]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #14: XREMain::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/nsAppRunner.cpp:4837]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #15: XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/nsAppRunner.cpp:4921]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #16: NS_internal_main(int,char * *,char * *) [browser/app/nsBrowserApp.cpp:293]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #17: wmain [toolkit/xre/nsWindowsWMain.cpp:129]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #18: static int __scrt_common_main_seh() [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:288]
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #19: KERNEL32.DLL + 0x12774
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | #20: ntdll.dll + 0x70d51
00:06:52 INFO -
00:06:52 INFO - GECKO(8548) | Exiting due to channel error.
00:06:52 INFO - GECKO(8548) | [GPU 8180, Main Thread] WARNING: Shutting down GPU process early due to a crash!: file z:/build/build/src/gfx/ipc/GPUParent.cpp, line 471
00:06:52 INFO - TEST-INFO | Main app process: exit 1
00:06:52 INFO - Buffered messages logged at 00:04:39
00:06:52 INFO - TEST-PASS | dom/media/test/test_playback.html | A valid string reason is expected

Flags: needinfo?(mfroman)

Ah, yes. The signature has changed. The original was complaining about an assert at line 2620, but this new issue is complaining about line 1134. It is easy enough to remove the assert, but the question becomes why the RDD process is failing to launch. I'll see if I can add some logging that might point to a specific problem area.

Flags: needinfo?(mfroman)
Blocks: RDD

If the RDD process is enabled and fails to start properly for some reason,
make sure we cannot accidentally fall back to decoding AV1 on the content
process.

Pushed by mfroman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9af879d2b1ae
pt 1 - eliminate fall back to av1 decoding on content process when RDD enabled. r=bryce
https://hg.mozilla.org/integration/autoland/rev/4625c4f69e31
pt 2 - remove assert, but warn if rddOpened is false. r=bryce
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → mfroman
No longer blocks: 1471535
Keywords: assertion
Regressed by: 1471535
See Also: → 1536126
Blocks: 1545575

Comment on attachment 9059516 [details]
Bug 1515497 - pt 1 - eliminate fall back to av1 decoding on content process when RDD enabled. r?bryce

Beta/Release Uplift Approval Request

  • User impact if declined: AV1 decoding could inadvertently happen on the content process instead of the RDD process. This patch will be necessary in order to uplift 1545575.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very small change, and limited in scope to only AV1 decoding.
  • String changes made/needed: n/a
Attachment #9059516 - Flags: approval-mozilla-beta?
Attachment #9059517 - Flags: approval-mozilla-beta?

Comment on attachment 9059516 [details]
Bug 1515497 - pt 1 - eliminate fall back to av1 decoding on content process when RDD enabled. r?bryce

Approved for 67 beta 15 thanks.

Attachment #9059516 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9059517 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Backed out because this is dependency of Bug 1545575 which got backed out for build bustages.

You need to log in before you can comment on or make changes to this bug.