Closed Bug 1515586 Opened 11 months ago Closed 10 months ago

'Force Attribution' does not work when using an Firefox browser that is opened inside dmg

Categories

(WebExtensions :: General, defect, P5)

66 Branch
Unspecified
macOS
defect

Tracking

(firefox65 affected, firefox66 affected)

RESOLVED WONTFIX
Tracking Status
firefox65 --- affected
firefox66 --- affected

People

(Reporter: vlad.jiman, Unassigned)

References

(Blocks 1 open bug)

Details

When using an MacOS and opening an Nightly browser without installing it, upon pressing the Force Attribution button nothing will happen.

Steps to reproduce:

1. Download any version of Nightly or Fx66.
2. Double click it and choose the Nightly logo in the loader instead of drag&dropping it into the Applications to install
3. Go to about:config and set the 'browser.newtabpage.activity-stream.asrouter.devtoolsEnabled' to True
4. Go to about:newtab#asrouter and scroll to the bottom of the page, press the 'Force Attribution' button
5. Open about:welcome

Expected:
The install addon message should be shown, depending on which addon has been added to the content field, about:welcome will be forced to show the first startup / install of that extension.

Actual:
Blank page, apparently when the browser has not been installed, Force Attribution does not populate the object with any values.
`Object { source: "addons.mozilla.org", campaign: "non-fx-button", content: "iridium@particlecore.github.io" }`
Blocks: 1468680
This is likely some issue with the writing of quarantine data for an app that is still inside the dmg.  I wouldn't consider this a big deal.
Priority: -- → P5
Summary: 'Force Attribution' does not work when using an Firefox browser that has not been added to Applications → 'Force Attribution' does not work when using an Firefox browser that is opened inside dmg
I'm not really certain where to put return to amo bugs.
Component: Request Handling → General

Since this is a testing/development only feature I think the current implementation is acceptable. Closing this unless someone thinks it's something we really need.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.