Closed Bug 1515789 Opened Last year Closed Last year

onLoadRequest is fired multiple times for a single page load

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android
defect

Tracking

(firefox66 wontfix, firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: rbarker, Assigned: snorp)

References

Details

(Whiteboard: [geckoview:fenix:p1])

Attachments

(1 file)

GeckoSession.NavigationDelegate.onLoadRequest() is called multiple time for a single page request. It isn't clear what is triggering the multiple calls. As an example, when loading codepen.io there are three onLoadRequests() calls made:

12-21 06:11:21.631  8852  8852 D VRB     : onLoadRequest: http://codepen.io/
...
12-21 06:14:21.186  8852  8852 D VRB     : onLoadRequest: https://i2.wp.com/static.codepen.io/assets/avatars/user-avatar-80x80-bdcd44a3bfb9a5fd01eb8b86f9e033fa1a9897c3a15b33adfc2649a002dab1b6.png?ssl=1
12-21 06:14:21.194  8852  8852 D VRB     : onLoadRequest: https://i2.wp.com/static.codepen.io/assets/avatars/user-avatar-80x80-bdcd44a3bfb9a5fd01eb8b86f9e033fa1a9897c3a15b33adfc2649a002dab1b6.png?ssl=1
Is this a regression? Does this happen for every page load?
OS: Mac OS X → Android
Hardware: x86_64 → Unspecified
Only certain pages seem to trigger this. I haven't had time to investigate what conditions cause multiple onLoadRequest to be called. It broke FxR user agent override because the subsequent calls to onLoadRequest were often not in the UA override list and was thus disabling it.
Priority: -- → P2
Duplicate of this bug: 1518102

P1 because this bug affects PWAs and home screen shortcuts, a use case that we'd like to promote in Fenix.

Priority: P2 → P1
Whiteboard: [geckoview:fenix:p1]
Assignee: nobody → snorp
Attachment #9037590 - Attachment description: Bug 1515789 - Ensure NavigationDelegate.onLoadRequest() is only called for toplevel redirects r?smaug → Bug 1515789 - Ensure nsILoadURIDelegate::loadURI() is only called for toplevel redirects. r?smaug
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6cf4cace2387
Ensure nsILoadURIDelegate::loadURI() is only called for toplevel redirects. r=smaug,geckoview-reviewers,esawin
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1517661
Duplicate of this bug: 1529768
You need to log in before you can comment on or make changes to this bug.