Closed Bug 1515878 Opened 9 months ago Closed 9 months ago

2.11 - 10.64% sessionrestore / sessionrestore_no_auto_restore / ts_paint / ts_paint_webext (linux64, linux64-qr, windows10-64, windows10-64-qr, windows7-32) regression on push c3e4039f9d1eb6f1bad5e75e0d2c4d46c8549acf (Wed Dec 19 2018)

Categories

(Core :: XPConnect, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: Bebe, Assigned: Waldo)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=c3e4039f9d1eb6f1bad5e75e0d2c4d46c8549acf

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 11%  sessionrestore linux64 pgo e10s stylo                          295.78 -> 327.25
 10%  sessionrestore windows7-32 opt e10s stylo                      331.09 -> 365.83
 10%  sessionrestore_no_auto_restore linux64 pgo e10s stylo          314.58 -> 345.83
 10%  sessionrestore_no_auto_restore windows10-64 opt e10s stylo     350.13 -> 383.67
  9%  sessionrestore windows10-64 opt e10s stylo                     330.83 -> 362.00
  9%  sessionrestore windows10-64 pgo e10s stylo                     311.39 -> 339.42
  9%  sessionrestore_no_auto_restore windows10-64 pgo e10s stylo     330.17 -> 358.33
  8%  sessionrestore_no_auto_restore windows7-32 opt e10s stylo      356.62 -> 386.92
  8%  sessionrestore_no_auto_restore windows7-32 pgo e10s stylo      335.78 -> 363.83
  8%  sessionrestore windows7-32 pgo e10s stylo                      317.83 -> 343.92
  7%  sessionrestore windows10-64-qr opt e10s stylo                  333.92 -> 358.58
  7%  ts_paint_webext windows7-32 pgo e10s stylo                     330.91 -> 355.17
  7%  ts_paint windows10-64 opt e10s stylo                           337.74 -> 361.42
  7%  ts_paint windows7-32 pgo e10s stylo                            330.39 -> 352.83
  7%  ts_paint_webext windows10-64 opt e10s stylo                    339.04 -> 361.42
  6%  ts_paint windows10-64 pgo e10s stylo                           321.61 -> 341.83
  6%  ts_paint windows10-64-qr opt e10s stylo                        337.78 -> 357.83
  6%  ts_paint windows7-32 opt e10s stylo                            350.75 -> 370.58
  6%  ts_paint_webext linux64 opt e10s stylo                         417.22 -> 440.75
  4%  sessionrestore linux64-qr opt e10s stylo                       795.46 -> 825.25
  2%  ts_paint linux64-qr opt e10s stylo                             858.78 -> 876.92


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=18385

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling
Blocks: 1492937, 1513237
Component: General → XPConnect
Product: Testing → Core
Version: Version 3 → unspecified
Bug 1492937 caused a performance regression 
Jeff can you take a look please?
Flags: needinfo?(jwalden)
There's a solid chance this will be fixed by the third patch in bug 1515801.  That patch is tryservering now, and assuming it comes back green I will land today.  Let's see what the ground looks like after that.
Flags: needinfo?(jwalden)
Okay, after a small sidetrack, I believe the last patch in bug 1515801 undid the perf changes.  Agreed?
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Assignee: nobody → jwalden
Target Milestone: --- → mozilla66

I confirm this got fixed!

== Change summary for alert #18485 (as of Thu, 27 Dec 2018 07:30:18 GMT) ==

Improvements:

9% sessionrestore linux64 opt e10s stylo 361.17 -> 328.08
9% sessionrestore_no_auto_restore linux64 pgo e10s stylo 345.25 -> 314.00
9% sessionrestore windows10-64 opt e10s stylo 361.58 -> 329.50
9% sessionrestore_no_auto_restore windows10-64 opt e10s stylo 383.50 -> 349.83
9% sessionrestore linux64 pgo e10s stylo 324.08 -> 295.83
8% sessionrestore windows7-32 opt e10s stylo 349.75 -> 320.08
8% sessionrestore_no_auto_restore windows10-64-qr opt e10s stylo 380.17 -> 348.08
8% sessionrestore_no_auto_restore windows10-64 pgo e10s stylo 359.08 -> 329.00
8% sessionrestore windows10-64-qr opt e10s stylo 359.83 -> 329.92
8% sessionrestore windows10-64 pgo e10s stylo 337.92 -> 310.08
8% sessionrestore_no_auto_restore windows7-32 pgo e10s stylo 359.67 -> 331.17
8% sessionrestore windows7-32 pgo e10s stylo 341.83 -> 314.75
8% sessionrestore_no_auto_restore linux64 opt e10s stylo 380.67 -> 350.58
7% sessionrestore_no_auto_restore windows7-32 opt e10s stylo 367.58 -> 340.58
7% ts_paint_webext windows10-64-qr opt e10s stylo 358.00 -> 333.00
7% ts_paint windows7-32 opt e10s stylo 351.00 -> 326.50
7% ts_paint windows10-64-qr opt e10s stylo 357.67 -> 333.42
7% ts_paint_webext windows7-32 opt e10s stylo 351.21 -> 328.17
7% ts_paint_webext windows10-64 opt e10s stylo 357.50 -> 334.25
7% ts_paint windows10-64 opt e10s stylo 356.58 -> 333.42
6% ts_paint windows10-64 pgo e10s stylo 339.17 -> 317.25
6% ts_paint_webext linux64 pgo e10s stylo 412.38 -> 386.08
6% ts_paint_webext windows10-64 pgo e10s stylo 337.75 -> 316.33
6% ts_paint_webext windows7-32 opt e10s stylo 372.50 -> 349.58
6% ts_paint windows7-32 pgo e10s stylo 344.00 -> 323.08
6% ts_paint linux64 opt e10s stylo 437.79 -> 411.83
6% ts_paint_webext windows7-32 pgo e10s stylo 345.50 -> 325.08
6% ts_paint linux64 pgo e10s stylo 410.21 -> 386.08
6% ts_paint windows7-32 opt e10s stylo 372.17 -> 350.33
6% ts_paint_webext linux64 opt e10s stylo 439.50 -> 414.00
6% sessionrestore_no_auto_restore windows7-32 opt e10s stylo 389.92 -> 368.17
5% sessionrestore windows7-32 opt e10s stylo 368.83 -> 350.92
3% sessionrestore linux64-qr opt e10s stylo 819.17 -> 796.31
3% ts_paint_webext windows7-32 pgo e10s stylo 355.26 -> 346.33
2% ts_paint windows7-32 pgo e10s stylo 352.83 -> 344.25
2% ts_paint_webext linux64-qr opt e10s stylo 876.58 -> 857.25
2% tp5o_webext windows7-32 opt e10s stylo 194.82 -> 190.88

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=18485

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.