Closed Bug 1516185 Opened Last year Closed Last year

Bug 1514853 disabled cookie restrictions on Nightly

Categories

(Firefox :: Protections UI, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1514853
Firefox 66

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

No description provided.
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/c37650fcf69c
Fix the name of the macro used in the patch for bug 1514853; r,a=me
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Backed out 2 changesets (Bug 1514853, Bug 1516185) for browser_contentblocking.js failures a=backout

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=c37650fcf69ca288b874f4bb780831af68dce283&selectedJob=218619396

Backout link: https://hg.mozilla.org/mozilla-central/rev/f87b08093cd56ae66434ab8a42759b37e3e4198a

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=218619396&repo=mozilla-central&lineNumber=8964

10:41:12     INFO - Entering test bound testContentBlockingCustomCategory
10:41:12     INFO - Buffered messages logged at 10:41:03
10:41:12     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref urlclassifier.trackingTable remains as default value - 
10:41:12     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref privacy.trackingprotection.enabled remains as default value - 
10:41:12     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref privacy.trackingprotection.pbmode.enabled remains as default value - 
10:41:12     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref network.cookie.cookieBehavior remains as default value - 
10:41:12     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | browser.contentblocking.category has been set to custom - 
10:41:12     INFO - Buffered messages logged at 10:41:04
10:41:12     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | browser.contentblocking.category has been set to custom - 
10:41:12     INFO - Buffered messages finished
10:41:12     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Uncaught exception - undefined - timed out after 50 tries.
10:41:12     INFO - Leaving test bound testContentBlockingCustomCategory
...
10:41:36     INFO - GECKO(2099) | [Parent 2099, Main Thread] WARNING: NS_FAILED internal_GetScalarByEnum for CHILD: file /builds/worker/workspace/build/src/toolkit/components/telemetry/core/TelemetryScalar.cpp, line 2161
10:41:40     INFO - GECKO(2099) | --DOMWINDOW == 17 (0x118a36400) [pid = 2099] [serial = 388] [outer = 0x0] [url = about:preferences#privacy]
10:41:40     INFO - GECKO(2099) | --DOMWINDOW == 16 (0x11a367800) [pid = 2099] [serial = 396] [outer = 0x0] [url = about:preferences#privacy]
10:42:23     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 1
10:43:53     INFO - Not taking screenshot here: see the one that was previously logged
10:43:53     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Test timed out - 
10:43:54     INFO - GECKO(2099) | MEMORY STAT | vsize 4552MB | residentFast 514MB | heapAllocated 109MB
10:43:54     INFO - TEST-OK | browser/components/preferences/in-content/tests/browser_contentblocking.js | took 180361ms
10:43:54     INFO - Not taking screenshot here: see the one that was previously logged
10:43:54     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Found a tab after previous test timed out: about:blank - 
10:43:54     INFO - Not taking screenshot here: see the one that was previously logged
10:43:54     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Found a tab after previous test timed out: about:preferences#privacy - 
10:43:54     INFO - GECKO(2099) | ++DOCSHELL 0x114941800 == 1 [pid = 2104] [id = {1f7ee5b0-39e3-e641-b63a-6371c31e36c1}]
10:43:54     INFO - GECKO(2099) | ++DOMWINDOW == 1 (0x11e505c00) [pid = 2104] [serial = 22] [outer = 0x0]
10:43:54     INFO - GECKO(2099) | ++DOMWINDOW == 2 (0x11e5cd400) [pid = 2104] [serial = 23] [outer = 0x11e505c00]
10:43:54     INFO - GECKO(2099) | ++DOMWINDOW == 3 (0x11e5d2000) [pid = 2104] [serial = 24] [outer = 0x11e505c00]
10:43:54     INFO - checking window state
Status: RESOLVED → REOPENED
Flags: needinfo?(ehsan)
Resolution: FIXED → ---
Also backed out from beta:
Backed out changeset 440a80979d91 (Bug 1516185) for browser_contentblocking.js failures a=backout

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=440a80979d9114d97d15b6e6c84679b34c3ae347&selectedJob=218614577

Backout link: https://hg.mozilla.org/releases/mozilla-beta/rev/e8c9b7017023acbd81a5bbf3a9456d571502302b

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=218614577&repo=mozilla-beta&lineNumber=6632

[task 2018-12-23T18:07:40.184Z] 18:07:40     INFO - Entering test bound testContentBlockingCustomCategory
[task 2018-12-23T18:07:40.186Z] 18:07:40     INFO - Buffered messages logged at 18:07:32
[task 2018-12-23T18:07:40.187Z] 18:07:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref urlclassifier.trackingTable remains as default value - 
[task 2018-12-23T18:07:40.188Z] 18:07:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref privacy.trackingprotection.enabled remains as default value - 
[task 2018-12-23T18:07:40.189Z] 18:07:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref privacy.trackingprotection.pbmode.enabled remains as default value - 
[task 2018-12-23T18:07:40.191Z] 18:07:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | the pref network.cookie.cookieBehavior remains as default value - 
[task 2018-12-23T18:07:40.192Z] 18:07:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | browser.contentblocking.category has been set to custom - 
[task 2018-12-23T18:07:40.193Z] 18:07:40     INFO - Buffered messages logged at 18:07:33
[task 2018-12-23T18:07:40.194Z] 18:07:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_contentblocking.js | browser.contentblocking.category has been set to custom - 
[task 2018-12-23T18:07:40.195Z] 18:07:40     INFO - Buffered messages finished
[task 2018-12-23T18:07:40.197Z] 18:07:40     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Uncaught exception - undefined - timed out after 50 tries.
[task 2018-12-23T18:07:40.199Z] 18:07:40     INFO - Leaving test bound testContentBlockingCustomCategory
...
[task 2018-12-23T18:08:10.015Z] 18:08:10     INFO - GECKO(2278) | --DOMWINDOW == 2 (0x7f10d12e3000) [pid = 2439] [serial = 68] [outer = (nil)] [url = about:blank]
[task 2018-12-23T18:08:47.966Z] 18:08:47     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 1
[task 2018-12-23T18:10:17.961Z] 18:10:17     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-12-23T18:10:17.964Z] 18:10:17     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Test timed out - 
[task 2018-12-23T18:10:18.271Z] 18:10:18     INFO - GECKO(2278) | MEMORY STAT | vsize 2184MB | residentFast 391MB | heapAllocated 107MB
[task 2018-12-23T18:10:18.273Z] 18:10:18     INFO - TEST-OK | browser/components/preferences/in-content/tests/browser_contentblocking.js | took 180552ms
[task 2018-12-23T18:10:18.274Z] 18:10:18     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-12-23T18:10:18.275Z] 18:10:18     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Found a tab after previous test timed out: about:blank - 
[task 2018-12-23T18:10:18.292Z] 18:10:18     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-12-23T18:10:18.294Z] 18:10:18     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_contentblocking.js | Found a tab after previous test timed out: about:preferences#privacy - 
[task 2018-12-23T18:10:18.397Z] 18:10:18     INFO - GECKO(2278) | ++DOCSHELL 0x7f50c1998000 == 1 [pid = 2506] [id = {42ab7cb5-e00b-4125-aba8-913e44da5ded}]
[task 2018-12-23T18:10:18.401Z] 18:10:18     INFO - GECKO(2278) | ++DOMWINDOW == 1 (0x7f50c1d55800) [pid = 2506] [serial = 19] [outer = (nil)]
[task 2018-12-23T18:10:18.454Z] 18:10:18     INFO - GECKO(2278) | ++DOMWINDOW == 2 (0x7f50c20c8800) [pid = 2506] [serial = 20] [outer = 0x7f50c1d55800]
[task 2018-12-23T18:10:18.503Z] 18:10:18     INFO - GECKO(2278) | ++DOMWINDOW == 3 (0x7f50c20ca800) [pid = 2506] [serial = 21] [outer = 0x7f50c1d55800]
[task 2018-12-23T18:10:18.519Z] 18:10:18     INFO - checking window state
I'll fix this in bug 1514853.
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1514853
You need to log in before you can comment on or make changes to this bug.