Stop offering Yandex as default search engine for Russia

RESOLVED WONTFIX

Status

()

defect
P5
normal
RESOLVED WONTFIX
6 months ago
2 months ago

People

(Reporter: meikathura, Unassigned)

Tracking

64 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

Yandex censors search results. For example it remove Telegram website, because this link is present in the register of the domain names, website references
and network addresses that allow identifying websites containing information
circulation of which is forbidden in the Russian Federation.

https://ria.ru/20181226/1548767539.html

This is censorship. Yes, imposed by the government, but censorship, because Telegram was blocked not because of DMCA or copyright claims.

https://en.wikipedia.org/wiki/Blocking_Telegram_in_Russia

As many other domains too.
Component: Untriaged → Search
Summary: Stop offer Yandex as default browser for Russia → Stop offering Yandex as default search engine for Russia

Comment 1

6 months ago
Please let me clear up the situation a little bit. 

TLDR: Yandex as Mozilla's partner is a default search engine in Russian version of Firefox and it censors search results. Please consider measures to provide uncensored search results for Russian users.

In recent years the Russian government has passed laws that regulate information exchange on the Internet and introduce a blacklist of blocked websites. Initially the law was intended to block only resources that were terrorism-related or harmful for minors, but later the number of reasons for blocking was extended (including, for example, sites that call for unapproved protest rallies - they must be blocked with highest priority within 24 hours), and more new laws were added - laws regulating online news aggregators, instant messengers, Internet search engines. The sites offering services (like proxy or VPN) that allow to bypass blocking were declared illegal and are to be blocked too.

Eventually the government began to use these laws to block websites for political reasons - a recent example is a website for "smart voting" against pro-government party that has been blocked several weeks after public release [1]. Another example is a case when Youtube had removed an ads calling for a protest rally against a pension reform on the voting day [2]. 

The brief history of blocking access to sites can be found in Wikipedia [3]. For those who are curious, a (unofficial, but correct) detailed list of blocked websites can be found here [4]. 

A recent (in 2017) addition to the law is a requirement that search engines that target ads for Russian users must remove blocked websites from search results. One might think that doesn't make sense because the access to the site is blocked anyway; in reality the blocking system has many flaws and some sites bypass it. For example, while Telegram messenger is blocked for non-cooperationg with law enforcement agencies, it is in fact working despite the government was blacklisting up to 20M IP addresses trying to disrupt its work [5].

Two most popular search engines in Russia are Yandex and Google. They are closely competing and now their shares are approximately 50/50. While Yandex is removing blocked sites from search results for Russian users, Google isn't. This is easy to check by searching for a "smart voting" website in both systems: [6], [7] (if you are opening the link from outside Russia, you might get non-censored search resutls).

Yandex is the default search engine in Russian Firefox. While it might be not Yandex's fault, the fact is that Yandex is currently providing censored search results for users in Russia. I think that it neither conforms to the values declared in Mozilla's Mission [8] nor does it match the high expectations of Firefox users. They do not deserve low quality censored search results.

Therefore I am asking whether Mozilla could consider some steps to provide better, non-censored search results. This can be achieved in different ways. For example, Mozilla could ask Yandex to make an exception and find a way to provide users having "Firefox" in User-Agent field with uncensored results (or users having "Mozilla" in UA? Just kidding). Or, maybe Mozilla could consider changing default search engine for Russian users and adding a warning about Yandex's censorship. Also, search engines that do not target ads for Russian users are outside of the scope of the law currently.

As Yandex and Google are competitors, breaking a partnership with Mozilla can cause noticeable financial loss to Yandex; this could motivate them to find a workaround for providing better search results for Mozilla's users. On the other hand, this could motivate the government to take measures against Google or Mozilla as well.

I must warn that providing a service to bypass blocking is illegal in Russia. While changing a default search engine technically is not a violation of the law, standing up against the censorship might eventually get Mozilla's website blacklisted too.

I will be happy to provide any further details about the issue, links and explanations if that is necessary.

[1] https://www.rferl.org/a/navalny-s-smart-voting-website-blocked-in-russia/29664835.html
[2] https://www.bbc.co.uk/news/technology-45471519
[3] https://en.wikipedia.org/wiki/List_of_websites_blocked_in_Russia
[4] https://translate.google.com/translate?sl=ru&tl=en&u=https%3A%2F%2Freestr.rublacklist.net%2F
[5] https://en.wikipedia.org/wiki/Blocking_Telegram_in_Russia
[6] https://www.google.com/search?q=2019.vote
[7] https://yandex.ru/search/?lr=2&text=2019.vote
[8] https://www.mozilla.org/en-US/mission/

Updated

5 months ago
Priority: -- → P5

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.