Closed Bug 1516735 Opened 10 months ago Closed 10 months ago

Android build fails with "error: implicit declaration of function 'arc4random_buf'"

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1516642

People

(Reporter: botond, Unassigned)

Details

(Keywords: regression)

Trying to build latest m-c for Android, with warnings-as-errors enabled. Getting the following error:

16:55.42 parser/expat/lib/xmlparse.c:844:3: error: implicit declaration of function 'arc4random_buf' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
16:55.42   arc4random_buf(&entropy, sizeof(entropy));
16:55.42   ^
16:55.42 1 error generated.
And, after disabling warnings-as-errors, it fails with a linker error instead:

21:43.06 /home/botond/.mozbuild/android-ndk-r15c/toolchains/arm-linux-androideabi-4.9/prebuilt/linux-x86_64/lib/gcc/arm-linux-androideabi/4.9.x/../../../../arm-linux-androideabi/bin/ld: error: hidden symbol 'arc4random_buf' is not defined locally
Summary: Android build with warnings-as-errors fails with "error: implicit declaration of function 'arc4random_buf'" → Android build fails with "error: implicit declaration of function 'arc4random_buf'"
Dupe of Bug 1516642.  We'll try to address this over there.
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1516642
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.