onmouseover tooltips float underneath scrollbar

RESOLVED INVALID

Status

()

Core
Layout
P4
normal
RESOLVED INVALID
15 years ago
2 years ago

People

(Reporter: David Smith, Unassigned)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
The sidebar on the right side of the page (Early Reviews, etc.) is set up with
onmouseovers that bring up a tooltip that displays the entire name of the title.
 However, when the tooltip comes up and the mouse is far enough to the right,
the tooltip is drawn underneath the vertical scrollbar.  This pushes the
apparant width of the page out, and a horizontal scrollbar appears.  If you move
the mouse to the right (including after moving the scrollbar over) the
horizontal scrollbar will get bigger.  If you move it to the left while keeping
the tooltip up, it will make the horizontal scrollbar shrink and eventually
disappear.  If you move in such a way that the tooltip disappears, the scrollbar
remains as you last left it.

Expected:
The tooltip will not display any further to the right than the inside edge of
the scrollbar.  The area the scrollbar covers should not be considered an active
part of the page.
(Reporter)

Comment 1

15 years ago
Meant to include -  this is what the code fragment looks like:

<a onmouseover="return overlib('Armitage III: Dual Matrix (Special Edition)');"
onmouseout="return nd();" href="/reviews/viewreview.php?review=919">Armitage
III: Du...</a>

-> Layout
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: imajes-qa → petersen

Comment 3

15 years ago
Confirming in the OS X (2002-07-23-05) and Windows Me (2002-07-22-08) builds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4

Updated

15 years ago
Target Milestone: --- → Future
I haven't completely analysed the script, but isn't this more an evangelism issue?
This is the script that makes the floating tooltips:
http://www.animeondvd.com/overlib.js
In function placeLayer() I found this (at line nr 926):
if (ie4) iwidth = o3_frame.document.body.clientWidth;
if (ns4) iwidth = o3_frame.innerWidth; // was screwed in mozilla, fixed now?
if (ns6) iwidth = o3_frame.outerWidth;

So IE gets document.body.clientWidth which is the width of the page minus the
scrollbars. And Mozilla gets window.outerWidth, which is the width of the page
(with the width of the scrollbars).
I think that is the cause of the bug.
Assignee: attinasi → nobody
QA Contact: chrispetersen → layout
Site gone, lacks enough details
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.