Closed Bug 1517022 Opened 2 years ago Closed 2 years ago

Intermittent dom/media/test/test_mediarecorder_record_gum_video_timeslice_mixed.html | Test timed out.

Categories

(Core :: Audio/Video: Recording, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: pehrsons)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell fixed:backout])

Attachments

(1 file)

Filed by: rgurzau [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=219412589&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/VCsry3L_R-qz23i46WQkPg/runs/0/artifacts/public/logs/live_backing.log

16:33:25     INFO - TEST-UNEXPECTED-FAIL | dom/media/test/test_mediarecorder_record_gum_video_timeslice_mixed.html | Test timed out. 
16:33:25     INFO -     SimpleTest.ok@SimpleTest/SimpleTest.js:275:7
16:33:25     INFO -     reportError@SimpleTest/TestRunner.js:121:7
16:33:25     INFO -     TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
16:33:25     INFO -     TestRunner.runTests/<@SimpleTest/TestRunner.js:381:9
16:33:25     INFO -     promise callback*TestRunner.runTests@SimpleTest/TestRunner.js:368:50
16:33:25     INFO -     RunSet.runtests@SimpleTest/setup.js:201:3
16:33:25     INFO -     RunSet.runall@SimpleTest/setup.js:180:5
16:33:25     INFO -     hookupTests@SimpleTest/setup.js:273:5
16:33:25     INFO - parseTestManifest@http://mochi.test:8888/manifestLibrary.js:36:5
16:33:25     INFO - getTestManifest/req.onload@http://mochi.test:8888/manifestLibrary.js:49:11
16:33:25     INFO - EventHandlerNonNull*getTestManifest@http://mochi.test:8888/manifestLibrary.js:45:3
16:33:25     INFO -     hookup@SimpleTest/setup.js:253:5
16:33:25     INFO - EventHandlerNonNull*@http://mochi.test:8888/tests?autorun=1&closeWhenDone=1&consoleLevel=INFO&manifestFile=tests.json&dumpOutputDirectory=c%3A%5Cusers%5Ctask_1546271190%5Cappdata%5Clocal%5Ctemp&cleanupCrashes=true:11:1
16:33:26     INFO - GECKO(2680) | MEMORY STAT | vsize 682MB | vsizeMaxContiguous 826MB | residentFast 135MB | heapAllocated 17MB
16:33:26     INFO - TEST-OK | dom/media/test/test_mediarecorder_record_gum_video_timeslice_mixed.html | took 310701ms
16:33:25     INFO - Buffered messages logged at 16:31:35
16:33:25     INFO - dataavailable fired, size=0, memory=true, file=false
16:33:25     INFO - dataavailable fired, size=3000, memory=false, file=true
16:33:25     INFO - Stopping recording
16:33:25     INFO - dataavailable fired, size=2930, memory=true, file=false
16:33:25     INFO - Starting playback. Blob-size=3637085
16:33:25     INFO - Buffered messages finished
Component: Audio/Video: Playback → Audio/Video: Recording
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Regressed by: 1014393
Whiteboard: [retriggered] → [retriggered][stockwell fixed:backout]
Assignee: nobody → apehrson

This changes from trying to encode at the memory-blob-limit to requesting small
blobs for ensuring a memory blob and increasingly large blobs for ensuring a
file blob.

A theory why this would end up failing on Android hw is because fake video on
Android is 320x240 as opposed to 640x480 on other platforms. Add timing changes
from bug 1014393 and the permafail on Android doesn't seem surprising.

Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/92a83858c472
Improve logic for ensuring mixed-blobs. r=jib
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.